Item12518: add support for jquery-2.x without disturbing oldIEs

pencil
Priority: Enhancement
Current State: Closed
Released In: 1.1.9
Target Release: patch
Applies To: Extension
Component: JQueryPlugin
Branches: Release01x01
Reported By: MichaelDaum
Waiting For:
Last Change By: GeorgeClark
This is done via conditional comments interpreted by IE:

<!--[if lt IE 9]>
<script type='text/javascript' src='%PUBURLPATH%/%SYSTEMWEB%/JQueryPlugin/$jQueryIE.js'></script>
<![endif]-->
<!--[if gte IE 9]><!-->
<script type='text/javascript' src='%PUBURLPATH%/%SYSTEMWEB%/JQueryPlugin/$jQuery.js'></script>
<!--<![endif]-->

This adds YACS (yet another configuration setting) ... {JQueryVersionForOldIEs} (default empty):

  • if set to empty, all browsers get the same library version
  • if set to some jquery-1.x setting, oldIEs will be served this one while modern browser benefit from more speed in newer versions of jquery

A standard setting would be:

  • {JQueryVersion} = jquery-2.0.1
  • {JQueryVersionForOldIEs} = jquery-1.10.0

The jquery-2.x and jquery-1.x branches are kept api compatible for the next foreseeable future. Thus keeping backwards compatibility while leaving room for further improvements in newer browsers.

-- MichaelDaum - 30 May 2013

 
Topic revision: r6 - 19 Nov 2013, GeorgeClark - This page was cached on 31 May 2016 - 16:18.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License