You are here: Foswiki>Tasks Web>Item12478 (19 Nov 2013, GeorgeClark)Edit Attach

Item12478: Documentation incorrect for URLPARAM default= parameter.

pencil
Priority: Urgent
Current State: Closed
Released In: 1.1.9
Target Release: patch
Applies To: Engine
Component:
Branches: Release01x01 trunk
Reported By: MichaelDaum
Waiting For:
Last Change By: GeorgeClark
I was wondering why this

%URLPARAM{"q" default="foo"}% = foo

Does not return the default value when you click me.

From the docu

default="..."    Default value in case parameter is empty or missing

However when q is empty in the above "click me" test, no "foo" no see.

This is so basic, I wonder why this is going wrong...

-- MichaelDaum - 23 Apr 2013

This is incorrect documentation. I checked and it has been incorrect since (tm)wiki was first checked into CVS. Specifying ?q= gives q the empty value. The default only applies if it is given no value.

Documentation requires correction.

-- CrawfordCurrie - 23 Apr 2013

 

ItemTemplate edit

Summary Documentation incorrect for URLPARAM default= parameter.
ReportedBy MichaelDaum
Codebase 1.1.8, trunk
SVN Range
AppliesTo Engine
Component
Priority Urgent
CurrentState Closed
WaitingFor
Checkins distro:7654513923c6 distro:1f36d96ae23f
TargetRelease patch
ReleasedIn 1.1.9
CheckinsOnBranches Release01x01 trunk
trunkCheckins distro:1f36d96ae23f
Release01x01Checkins distro:7654513923c6
Topic revision: r8 - 19 Nov 2013, GeorgeClark - This page was cached on 05 Dec 2016 - 12:04.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License