Item12345: upgrade jquery and other 3rd party plugins

pencil
Priority: Enhancement
Current State: Closed
Released In: 1.1.9
Target Release: patch
Applies To: Extension
Component: JQueryPlugin
Branches: Release01x01 trunk
Reported By: MichaelDaum
Waiting For:
Last Change By: GeorgeClark
  • jquery
  • jquery-ui
  • pnotify
  • scrollto
  • masonry
  • cycle (cycle2 is available too though probably incompatible)
  • form
  • blockui

-- MichaelDaum - 15 Jan 2013

When testing javascript against 1.9.0, see https://github.com/jquery/jquery-migrate/blob/master/warnings.md

All plugins we ship with JQueryPlugin should be able to run 1.9.0 without having to activate jquery.migrate at the same time.

-- MichaelDaum - 16 Jan 2013

Useful resources:

-- MichaelDaum - 14 May 2013

I don't know if this deserves a separate task: the currently distributed (Foswiki 1.1.8) version of scrollto (1.4.2) is not working with jquery 1.8.2. See https://github.com/flesler/jquery.scrollTo/issues/22. I manually updated the scrollto to 1.4.6 (in a new 1.1.8 installation) and it works again.

-- LynnwoodBrown - 24 May 2013

Released in JQueryPlugin 4.70.

-- MichaelDaum - 29 May 2013
 
Topic revision: r21 - 19 Nov 2013, GeorgeClark - This page was cached on 30 Jun 2016 - 10:47.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License