Item11167: Tests that require JQuery plugins will fail unless enabled

pencil
Priority: Normal
Current State: Closed
Released In: n/a
Target Release: n/a
Applies To: Extension
Component: UnitTestContrib
Branches:
Reported By: GeorgeClark
Waiting For:
Last Change By: MichaelDaum
Extension settings are not merged during normal operation. It's assumed that they will be picked up when configure is run. pseudo-install.pl -A doesn't merge in the defaults from extensions.

Tests that require JQuery plugins need to enable them. -- GeorgeClark - 04 Oct 2011

I've fixed this for the one failing test. HTMLValidationTests. But is the right solution to add code to enable the required plugins as part of the test, or should pseudo-install -A set the defaults from Foswiki.spec and from each default core extension's Config.spec.

-- GeorgeClark - 06 Oct 2011
 

ItemTemplate edit

Summary Tests that require JQuery plugins will fail unless enabled
ReportedBy GeorgeClark
Codebase 1.1.3, trunk
SVN Range
AppliesTo Extension
Component UnitTestContrib
Priority Normal
CurrentState Closed
WaitingFor
Checkins distro:4094cf8ac765 distro:eaf48720d45d
TargetRelease n/a
ReleasedIn n/a
CheckinsOnBranches
trunkCheckins
masterCheckins
ItemBranchCheckins
Release02x01Checkins
Release02x00Checkins
Release01x01Checkins
Topic revision: r5 - 14 Oct 2020, MichaelDaum - This page was cached on 14 Oct 2020 - 12:11.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy