Item10302: Update to JQuery 1.7.1 and make it the default version

Priority: CurrentState: AppliesTo: Component: WaitingFor:
Urgent Closed Extension JQueryPlugin  
Resolving incompatibilities/problems introduced with the latest of the 1.4 series

-- PaulHarvey - 31 Jan 2011

As far as I see all of the plugins shipped as part of the latest JQueryPlugin are compatible with jQuery-1.4 ... Alas jquery-1.6.1 is out and the game begins from the start.

-- MichaelDaum - 25 May 2011

Please all: switch your env to jquery-1.6.3 and see what errors arise.

-- MichaelDaum - 12 Sep 2011

There seems to be an issue with textboxlist. I can see autocomplete requests are fired, but no autocomplete UI appears.

Also: it's firing off in a "term" URLPARAM, whereas the existing usage uses "q".

Is this breaking change intentional/necessary?

-- PaulHarvey - 13 Sep 2011

This is due to jquery.autocomplete being deprecated. Please run configure again, disable jquery.autocomplete. It is now replaced by ui::autocomplete. See Item10880.

-- MichaelDaum - 13 Sep 2011

We need a strategy for upgraders.

  • Will disabling autocomplete be required of all people upgrading to new JQueryPlugin?
  • Is autocomplete the only deprecated plugin?

I can create configure checkers to flag these lingering modules as warnings/errors.

-- PaulHarvey - 14 Sep 2011

Having trouble making JQueryTabpane work properly.

  • When a page is first loaded, it seems after and afterload events are firing for all tabs, not just the default displayed tab
  • When you do click on a tab, the events are fired twice.

-- PaulHarvey - 14 Sep 2011

Paul, could you add some example code that illustrates the problem, please?

JQueryPlugin needs to be synced to the release branch. Making this a release stopper not to forget about it.

-- MichaelDaum - 30 Sep 2011

http://foswiki.org/System/JQueryAjaxHelper?raw=on shows that JQUERYPLUGIN::AUTOCOMPLETE has been updated to JQUERYPLUGIN::UI::AUTOCOMPLETE in one place but not another. Please update the other place. Also, I noticed that it has JQREQUIRE{"ui"} but not JQREQUIRE{"ui::autocomplete"} as http://foswiki.org/System/JQueryUIAutocomplete seems to indicate. Not sure if that's correct.

-- JayenAshar - 04 Dec 2011

I tried to get the jump box example working over in JQueryAjaxHelperCopy.
  1. i added JQREQUIRE{"ui::autocomplete"} to load the autocomplete.init.js
  2. i changed requires="JQUERYPLUGIN::UI::AUTOCOMPLETE" (as commented above)
  3. i removed the format=opts.format flag passed to System/JQueryAjaxHelper. Adding " to the format in the IF macro in the class attribute in the input field in the jumpbox section didn't work (no matter how much i tried to escape it). Adding " to the format="opts.format" flag passed to System/JQueryAjaxHelper worked, but resulted in " in the reply.

-- JayenAshar - 04 Dec 2011

Jayen, this is fixed now. Thanks.

I think we can close this one now. Note: that jquery-1.6.4 isn't the latest jquery version anymore. Latest by now is 1.7.1 which I am using successfully using JQueryPlugin from trunk.

-- MichaelDaum - 05 Dec 2011

Not as awesome as it used to be. frown The global jump example listed the web name in the completion list, but now it doesn't, and so a search for WebAtom doesn't tell you which web's WebAtom you might jump to.

Also, the other, non-jump examples on the page don't work. They don't invoke the autocompleter, nor give a js error.

-- JayenAshar - 07 Dec 2011

See Item11335 for more details.

-- JayenAshar - 07 Dec 2011

Work on the ajax helper examples is now tracked on Item11335. I especially like the move towards syncing trunk with current stable by George ... which I didn't dare to do as this would have broken feature freeze: see the new jqLoader module that will be shipped with 1.1.4 already (yay). But as George is the release manager it is okay I guess wink .

-- MichaelDaum - 11 Dec 2011
 
Topic revision: r27 - 17 Dec 2011, GeorgeClark
 
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. see CopyrightStatement. Creative Commons License