Foswiki on GitHub is open for business! Next release meeting: Monday September 29, 1300Z

Item10148: Upgrade to jquery-ui to 1.8

Priority: CurrentState: AppliesTo: Component: WaitingFor:
Enhancement Closed Extension JQueryPlugin  
jqgrid 3.8 depends on ui 1.8.

Sadly, the upgrade path from ui 1.7 -> 1.8 requires modification of any code that was using 1.7's widget factory, among other things.

See: http://jqueryui.com/docs/Upgrade_Guide

Affected JQueryPlugin plugins:
  • Farbtastic

... and none others that I could see. MichaelDaum, what else is there to worry about? And should we consider supporting wiki-apps that still need the old version of something?

Eg. %JQREQUIRE{"ui" version="1.7"}%

-- PaulHarvey - 11 Dec 2010

Actually, scratch the version idea. It could be come terribly complex. Needs a feature proposal.

-- PaulHarvey - 11 Dec 2010

I've got an update for all of JQueryPlugin to switch to 1.4.3. This is required for latest jquery ui. And this in turn triggers a couple of other updates. There were a couple of things to sort out. For one jquery.autocomplete itself is deprecated and has been reimpleneted in jquery.ui. This new autocomplete triggers a couple of js errors that I was unable to figure out what this is. So I disabled jquery.ui's autocomplete so that we can still use the old one, which still does fine. There's also a TwistyPlugin weirdo where twisties won't open under certain circumstances due to the braindeadiness inside. Have that working with a jquery-1.4.3 again reverting some of the changes AC did lately. Nother thing to keep in mid: jqgrid doesn't yet work with jquery-1.4.4 while jquery-1.4.3 is just fine.

Finally, the next JQueryPlugin will kick out all legacy jquery versions 1.2 and 1.3 as these are not compatible with jquery-ui at all ... and basically shouldn't be used anymore from that point on.

Will checkin these changes asap.

-- MichaelDaum - 11 Dec 2010

Part of Item9739

-- MichaelDaum - 13 Dec 2010

ItemTemplate edit

Summary Upgrade to jquery-ui to 1.8
ReportedBy PaulHarvey
Codebase trunk
SVN Range
AppliesTo Extension
Component JQueryPlugin
Priority Enhancement
CurrentState Closed
WaitingFor
Checkins
TargetRelease patch
ReleasedIn 1.1.3
Topic revision: r5 - 16 Apr 2011, KennethLavrsen
 
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. see CopyrightStatement. Creative Commons License