This question about Installation of Foswiki: More info required

utf8 symbol does not map to Unicode

I am attempting to install Foswiki 2.0.1 on Mac OS X (10.9).

I have run configure. I have not copied any data into the tree yet.

I then clicked to view the site. I got this error:

Foswiki detected an internal error - please check your Foswiki logs and webserver logs for more information.

utf8 "\xA9" does not map to Unicode

The Apache (2.2.4) error log repeats, over and over:

error_log:[Mon Aug 24 15:55:03 2015] [error] [client 207.46.13.95] utf8 "\\xA9" does not map to Unicode at /System/Library/Perl/5.10.0/darwin-thread-multi-2level/Encode.pm line 162.

-- VickiBrown - 24 Aug 2015

The hex A9 character is the © - copyright symbol. If you've only installed extensions, then it is probably non-ASCII text in the extension topics. We need to find and re-release extensions that contain non-ASCII characters.

If you migrated your local data, did you follow the steps to use either bulk_copy or the CharsetConverterContrib to migrate the data from ISO-8859-1 to UTF-8? The other option is to set the {Store}{Encoding} to iso-8859-1 or whatever character set your migrated data is using.

-- GeorgeClark - 25 Aug 2015

As I said, I have not yet migrated any data. I tried a grep for xA9 in the foswiki subdirectories. No results. And now configure won;t work either.

I suppose I could try the bulk_copy script for the System directory...

-- VickiBrown - 25 Aug 2015

NO no... don't bulk_copy System. That will break your installation. Might want to hit us up on IRC for questions like this.

-- GeorgeClark - 25 Aug 2015

oookay... so... how do I find this error if grep isn't working?

-- VickiBrown - 25 Aug 2015

The user who did most of the utf-8 torture testing was running on Darwin OS/X. You might enable Asserts in bin/LocalLib.cfg. We need to figure out what topic has the bad character, and that should give you a more detailed stack trace. you mentioned in another question behavior of the extension installer, so I'm suspicious that this might be an extension issue. You might try a reinstall but without any optional extensions, and then install one at a time and test each one.

Tasks.Item13483 list extensions that have been tested with Foswiki 2.0 and utf-8 data.

-- GeorgeClark - 25 Aug 2015

If this is happening on every page, did you copy over your SitePreferences, and is the copyright symbol in your copyright statement? That would pretty much kill every page.

-- GeorgeClark - 25 Aug 2015

I edited LocalSite.cfg manually and turned off all plugins, then turned them on a few at a time. The problem appears and disappears if I enable/disable TreePlugin.

-- VickiBrown - 25 Aug 2015

According to Tasks.Item13483

TreePlugin ALERT! Works, but TreePlugin topic contains a non-utf8 copyright symbol.

Unfortunately, this non-utf8 copyright symbol breaks the entire site, so I wouldn't call that works.

I have filed Tasks/Item13634.

-- VickiBrown - 25 Aug 2015

The copyright symbol doesn't broke the "entire" site, just emits many error messages, and the plugin's topic itself cannot be viewed.

This issue is now fixed.

However, here is another problem - pure OS X specific. See: Tasks.Item13660

-- JozefMojzis - 01 Sep 2015
 

QuestionForm edit

Subject Installation of Foswiki
Extension
Version
Status More info required
Related Topics
Topic revision: r8 - 01 Sep 2015, JozefMojzis - This page was cached on 10 Jan 2018 - 04:51.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License