This question about Using an extension: Needs followup in Tasks

natskin: copy topic results in 500 error

If I try to copy a topic in a web using a Natskin skin, I always get a 500 error.

However, the working/logs/error.log doesn't show what's wrong, nor does the Apache log of the hosting company.

What else can I check?

Kind regards


A few basic questions:
  • You've confirmed CopyContrib is installed?
  • Do you get the copy topic dialog pop-up dialog?
  • At what point do you get the 500 error?
  • What's the url that's associated with the 500 error?

I haven't run into this myself but I think we should be able to track it down.

-- Main.LynnwoodBrown - 19 Jul 2019 - 03:14

Hi Lynn,

The CopyContrib extension is installed.
Moreover, copying a topic from a web in the same foswiki site with PatternSkin works fine:

click 'More topic actions'
click 'Copy topic...'
► url:
EffortFormCopy (new)

However, if I use a web with NatSkin, it doesn't, e.g.:
click 'More' > 'Copy'
'Copy topic' dialog pops up
change Destination into 'HwTablets' and click on Copy
now the 500 error appears
the URL at that moment is:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

This is really strange. I'm rather stumped why it would not work in NatSkin but does with Pattern. One additional little detail I want to check: I notice that the two examples you gave were in different directories (webs). Could you just confirm that permissions are correct in the "Boossy" web? If you can create new topics in that web then it should be ok.

-- Main.LynnwoodBrown - 19 Jul 2019 - 21:19

In the Boossy web, I can create new topics, also the other More > Change actions are possible (Rename or move, Delete topic).

I've temporarily changed the skin from the Boossy web to Pattern => copy works fine

I've also tried to uninstall and reinstall NatSkin and the NatSkinPlugin. But the copy won't work with NatSkin.

The install.log of both NatSkin and NatSkinPlugin state the following :

Foswiki::Contrib::JQSelect2Contrib version > 1.01 required -- installed version is 02 Sep 2016 - Required

This extension (JQSelect2Contrib) is installed during the NatSkin installation, and is up to date (02 Sep 2016)... or not?!

The InstalledPlugins topic shows three errors, one related to NatSkin:

afterAttachmentSaveHandler DBCachePlugin
This handler is deprecated - please check for updated versions of the plugins that use it!
beforeAttachmentSaveHandler BlackListPlugin
This handler is deprecated - please check for updated versions of the plugins that use it!
endRenderingHandler NatSkinPlugin
This handler is deprecated - please check for updated versions of the plugins that use it!

Hi Lynn,

I have found the solution. I noticed I had the same problem with revisions (More > History section > View revision history > Compare / View last change). So it was about the copy and diff commands.

I then saw that a lot of files in the bin directory are virtually the same. I have copied the attach file as copy and diff and guess what! I now can copy or compare topics in webs that use the NatSkin!!!

I hope this doesn't imply a security issue...

Please try the latest version of CopyContrib. Thanks.

-- MichaelDaum - 26 Jul 2019

Hi Michael,

I tried the latest version of CopyContrib from 26/07/'19. However, this version also results in the same 500 error. If I then replace the 'copy' command in the bin directory by a copy of the attach command (my workaround from before), I don't get the 500 error, but the copied topic is empty. So I returned to my backup with the working workaround.

Kind regards


-- StijnBousard - 30 Jul 2019

Okay, I can see now that the copy cgi script is broken. I never noticed before as I am not using plain old cgi. Most people neither probably as you are strongly encouraged to use fastcgi.

-- MichaelDaum - 31 Jul 2019

QuestionForm edit

Subject Using an extension
Extension NatSkin, CopyContrib
Version Foswiki 2.1.6
Status Needs followup in Tasks
Related Topics Tasks.Item14684
Topic revision: r13 - 31 Jul 2019, MichaelDaum
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy