Item9860: There are still duplicate user names in the WikiGroups

Priority: CurrentState: AppliesTo: Component: WaitingFor:
Urgent Closed Engine    
Kenneth, George, as you know I have some trouble with Group management, so I take code form Foswikirev:9656

46930 21. Okt 07:51 TopicUserMapping.pm.9656 116328 21. Okt 07:55 Func.pm.9656 49753 21. Okt 07:56 Register.pm.9656 29662 21. Okt 07:56 Users.pm.9656

But I always see many duplicate user names in the Groups - if I remove such a name, it works. If I add the same name in this group or another the name will be duplicate - only in the view not in raw text viewed with vim.

Example: Members KatjaMehlhorn, UdoBoehm, JelmerBorst, AdminUser, MatthiasHenning, MatthiasHenning (this is copied from a view of an upgraded group)

The name MatthiasHenning I have removed and added with new UI. A duplicate name bug was in Item9811 and should be fixed with the Rev I updated.

As I understand I take the patches from Foswikirev:9656 (Kenneth) and should also have the changes from George Foswikirev:9584 ...

-- GuentherFischer - 21 Oct 2010

I am quite sure this is fixed but the fixes are made up from checkins on 5 different group related bugs and it is the sum that fixes this.

Try to pick the entire files TopicUserMapping.pm, Func.pm, Register.pm and Users.pm from svn

These 4 links always point to the latest and it is important that you update all 4 at the same time as change made are incompatible.

If this still does not work then we miss something in your bug description. Then a zip file with your failing example group topics will be a help. You can attach it to this bug report.

-- KennethLavrsen - 21 Oct 2010

there were some changes:
fischer@chinook 529 Downloads 31> ls -l Func.pm*
-rw-r--r-- 1 fischer urz 116735 21. Okt 06:44 Func.pm
-rw-r--r-- 1 fischer urz 116328 21. Okt 07:55 Func.pm.9656
fischer@chinook 530 Downloads 32> ls -l Users.pm*
-rw-r--r-- 1 fischer urz 29948 21. Okt 06:44 Users.pm
-rw-r--r-- 1 fischer urz 29662 21. Okt 07:56 Users.pm.9656
fischer@chinook 531 Downloads 33> ls -l Register.pm*
-rw-r--r-- 1 fischer urz 49753 20. Okt 23:51 Register.pm
-rw-r--r-- 1 fischer urz 49753 21. Okt 07:56 Register.pm.9656
fischer@chinook 532 Downloads 34> ls -l TopicUserMapping.pm*
-rw-r--r-- 1 fischer urz 46965 21. Okt 06:44 TopicUserMapping.pm
-rw-r--r-- 1 fischer urz 46930 21. Okt 07:51 TopicUserMapping.pm.9656

but no better result.

I will add 2 Groups:

AdminGroup with added 3 Users - all double in view and an not converted group

WBSgProduktionGroup - DirkKahlert is double

-- GuentherFischer - 21 Oct 2010

I created these groups on my server.

Where am I supposed to see the prople double?

-- KennethLavrsen - 21 Oct 2010

I have observed one thing. When I upgrade the old group it adds me to the list which it should not because I am an admin. But it should if I am not admin. But that is not what you report. I did not get any duplicate.

The upgraded topic is http://merlin.lavrsen.dk/foswiki11/bin/view/Main/WBSgAdminTwoGroup

I also need to look at the upgrade code with respect to removing Main prefix. But again that is not the problem Guenther has

Guenther. Can you try and guide me step by step what it is you do that gets you to duplicated users? And where you see the duplicated users.

-- KennethLavrsen - 21 Oct 2010

I've added 2 window dumps where you can see the doubles. In group topic view for upgraded topics and in WikiGroups too. Naturally there are no doubles in the old format, where the group definition is in topic text because the vie is without the new group UI (view).

What I have done:
  • installed Fwoswiki-1.1.0 from scratch
  • copied the user/group/main prefences from my FW-1.0.9
  • also I've added my ShibLogin.pm and some definitions in System - FWsystem on my side

I don't think it is around my Login changes - also if I use TemplateLogin I see the same result. If you don't have an idea I could make a new FW-1.1.0 installation only with user and groups added.

My server runs only with https and is for now only local. I could ask for open the ports in firewall tomorrow if you want to look at.

BTW: I have seen the Group on your serevr and I registered with my name and it looks well smile ... frown

-- GuentherFischer - 21 Oct 2010

Kenneth, I does a new install - only with some users and groups - no other changes.

Also I have copied the 4 Files in lib/... and also WikiGroups.txt, GroupViewTemplate.txt .

... and I don't see the doubles.

I think its the best you wait for my further results - magic.

-- GuentherFischer - 21 Oct 2010

I think I found the difference. I configure

$Foswiki::cfg{Register}{AllowLoginName} = 1;

I need it for my LoginManager (Shiboleth).

Till now with all Groups and Users ther was no double. then I make a "diff -r over the 2 Foswiki-1.1.0 pathes an see diff in the LocalSite.cfg., change this option and get the doubles ...

-- GuentherFischer - 21 Oct 2010

I have tried $Foswiki::cfg{Register}{AllowLoginName} = 1;

Still no duplicate entries. I am beginning to think it is your LoginManager that is playing games with us here.

Can you try just with plain normal ApacheLogin, TemplateLogin?

Are you using TopicUserMapping?

-- KennethLavrsen - 21 Oct 2010

Stop to think ... the ShibLogininManager isn't in the new test env. This was one reason to do a new installation from scratch. So I use for now TemplateLogin and TopicUserMapping.

But there is a difference on your side. My entry in WikiUsers is

I think you have added the second field?

Change it to

My login name is fischer ... and I think/hope you will see the double too.

You can try https://twiki-test.hrz.tu-chemnitz.de/bin/view/Main/WikiGroups firewall should be open for 443 ...

-- GuentherFischer - 22 Oct 2010

I have your username to fisher also on mine now. You registered while by test server did not have AllowLoginName enabled. It is now.

I will try and visit your site. One thing I notice is that not all names are duplicated so some names get duplicated and others don't

-- KennethLavrsen - 22 Oct 2010

Your site is not available through the firewall. But your old public 1.0.9 site is and guess what - you also have duplicate users in your groups on that so we are looking at an old bug in the user mapping.

Look at your 1.0.9 site (https://twiki.tu-chemnitz.de/bin/view/Main/WBSgAdminGroup) for the group WBSgAdminGroup

  • Set GROUP = Main.DirkKahlert, Main.BerndStoeckert

Dirk exists. But Bernd is an unknown user (link to none-existing user topic).

But on your WikiGroups topic the same group is shown as DirkKahlert DirkKahlert

So somehow these unknown users get mapped to the previous user.

Same error does not happen on my site. So what is it that makes your site map none-existing users to someone else (a serious issue)

I notice your 1.0.9 site runs some mod_perl plugin. Are you running under any kind of persistant perl? I run plain CGI.

-- KennethLavrsen - 22 Oct 2010

There was a typo in firewall rule, but this helps to see the WikiGroups in 1.0.9 smile

https://twiki.tu-chemnitz.de/bin/view/Main/UrzHiwiGroup

I don't belive its around non existing users - I have removed now the no existing user and the double will stay https://twiki.tu-chemnitz.de/bin/view/Main/TWikiGroups. Could it be in the implementation of the GROUPINFO macro.

-- GuentherFischer - 22 Oct 2010

I can also see a user like AlexanderStein is repeated in UrzHiwiGroup so it may not be a matter of just mapping unknown users because all users in that group are known.

Some users are repeated twice. And if they are - they are in all your groups.

So you have users in your .htpasswd file that are defined both by the WikiName and a login name.

I could imagine that some of your old users got registered first with WikiName and then later re-registered to using login name.

-- KennethLavrsen - 22 Oct 2010

I can reproduce the error if I have these two lines in my .htpasswd (password altered to garbage)

fischer:hdgyejskfhSdfsd:fischer@tu-chemnitz.eu
GuentherFischer:hdgyejskfhSdfsd:fischer@tu-chemnitz.eu

Then GROUPS macro shows Guenther twice.

Guenther I need to to confirm that you have the same user twice in your .htpasswd files both under login name and under wikiname.

I think we are near a root cause now and it is an old bug that may go back to TWiki and only related to GROUPS macro and the new GROUPINFO that we have in 1.1. If this is the root cause I can also resolve it.

-- KennethLavrsen - 22 Oct 2010

Yes - you are right. I have seen this in my .htpasswd. With the reregistration I got the loginname lines in the passwd file ...

-- GuentherFischer - 22 Oct 2010

I think I got it nailed now.

Foswikirev:9675 should have fixed it

-- KennethLavrsen - 22 Oct 2010

Thank you Kenneth ... now I can go forward to make Foswiki-1.1.0 or better 1.1.1 smile to my production release. First I have to do some more work on my ShibLoginManager.

-- GuentherFischer - 24 Oct 2010
 

ItemTemplate edit

Summary There are still duplicate user names in the WikiGroups
ReportedBy GuentherFischer
Codebase 1.1.0
SVN Range
AppliesTo Engine
Component
Priority Urgent
CurrentState Closed
WaitingFor
Checkins Foswikirev:9675 Foswikirev:9676
TargetRelease patch
ReleasedIn 1.1.1
Topic attachments
I Attachment Action Size Date Who Comment
AdminGroup.txttxt AdminGroup.txt manage 1.8 K 21 Oct 2010 - 09:47 GuentherFischer  
Bildschirmfoto-1.pngpng Bildschirmfoto-1.png manage 200.8 K 21 Oct 2010 - 15:15 GuentherFischer window dump wiki view of WikiGroups
Bildschirmfoto.pngpng Bildschirmfoto.png manage 179.2 K 21 Oct 2010 - 15:12 GuentherFischer window dump wiki view of AdminGroup
WBSgAdminGroup.txttxt WBSgAdminGroup.txt manage 0.4 K 21 Oct 2010 - 09:48 GuentherFischer  
Topic revision: r23 - 25 Oct 2010, KennethLavrsen
 
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. see CopyrightStatement. Creative Commons License