cross
Foswiki.org has been patched with a fix that will break all current logged in sessions. All users will have to log in again after the update.

Item8791: ONLYIF function used for conditional dependencies when installing extensions doesn't work.

Priority: Normal
Current State: Closed
Released In: 1.0.10
Target Release: patch
Applies To: Engine
Component: extender.pl
Branches:
Reported By: GeorgeClark
Waiting For: Foswiki:Main.GeorgeClark
Last Change By: KennethLavrsen
The regex that tests for "safe" ONLYIF conditions omits the $ - which is required to determine a module version.

We need this to work on 1.0.x if the ZonePlugin dependency is to be made conditional for only 1.0.x

This was already fixed in 1.1 as part of Tasks.Item8640

-- GeorgeClark - 28 Mar 2010

 

ItemTemplate edit

Summary ONLYIF function used for conditional dependencies when installing extensions doesn't work.
ReportedBy GeorgeClark
Codebase 1.0.9
SVN Range
AppliesTo Engine
Component extender.pl
Priority Normal
CurrentState Closed
WaitingFor Foswiki:Main.GeorgeClark
Checkins distro:8fe5a23de147
TargetRelease patch
ReleasedIn 1.0.10
Topic revision: r7 - 08 Sep 2010, KennethLavrsen - This page was cached on 01 Aug 2015 - 09:53. Get a fresh version here.
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License