You are here: Foswiki>Tasks Web>Item13519 (16 Nov 2015, GeorgeClark)Edit Attach

Item13519: Foswiki should clearly report missing dependencies. Don't crash with 500 Internal Server Error.

pencil
Priority: Urgent
Current State: Closed
Released In: 2.0.3
Target Release: patch
Applies To: Engine
Component: Configure
Branches: master
Reported By: ThanJay
Waiting For:
Last Change By: GeorgeClark
Original report: "Configuration page was not coming after did all set up for foswiki 2.0. Throws error as Can't locate Error.pm in @INC (you may need to install the Error module)"

-- ThanJay - 11 Jul 2015

This error am getting. Apache version: 2.2 Active Perl : 5.20

Can't locate Error.pm in @INC (you may need to install the Error module) (@INC contains: C:/foswiki20/lib C:/Perl/site/lib C:/Perl/lib . C:/foswiki20/lib/CPAN/lib) at C:/foswiki20/lib/Foswiki.pm line 48.
 at C:/foswiki20/lib/Foswiki.pm line 48.
   Foswiki::BEGIN() called at C:/foswiki20/lib/Foswiki.pm line 48
   eval {...} called at C:/foswiki20/lib/Foswiki.pm line 48
   require Foswiki.pm called at C:/foswiki20/bin/configure line 27
   main::BEGIN() called at C:/foswiki20/lib/Foswiki.pm line 48
   eval {...} called at C:/foswiki20/lib/Foswiki.pm line 48
BEGIN failed--compilation aborted at C:/foswiki20/lib/Foswiki.pm line 48.
 at C:/foswiki20/lib/Foswiki.pm line 48.
   require Foswiki.pm called at C:/foswiki20/bin/configure line 27
   main::BEGIN() called at C:/foswiki20/lib/Foswiki.pm line 48
   eval {...} called at C:/foswiki20/lib/Foswiki.pm line 48
Compilation failed in require at C:/foswiki20/bin/configure line 27.
 at C:/foswiki20/bin/configure line 27.
   main::BEGIN() called at C:/foswiki20/bin/configure line 27
   eval {...} called at C:/foswiki20/bin/configure line 27
BEGIN failed--compilation aborted at C:/foswiki20/bin/configure line 27.
 at C:/foswiki20/bin/configure line 27

-- ThanJay - 11 Jul 2015

Foswiki 2.0 no longer ships with any CPAN modules. The requirements are listed in the SystemRequirements.

For windows with active state perl, you should run "ppm", click on "Available packages" and then find and install the requirements listed in SystemRequirements.

Note that if for some reason you are unable to install perl modules, you can manually download and install the CpanContrib. It provides a subset of the perl modules. It cannot provide pre-compiled versions of any "xs" modules, so performance can be impacted and some code is unavailable.

-- Main.GeorgeClark - 11 Jul 2015 - 17:41

Same issue with 2.0.2 on Windows/Apache. Running tools dependencies returns the same error so that's not helping.

I don't think it's an issue with missing CPAN module at this stage it's an issue with @INC not including the CPAN folders.

On the same environment 1.1.8 used to work just fine probably cause it would default to FosWiki CPAN modules.

Somehow we don't include the perl installation CPAN modules.

-- StephaneLenclud - 08 Oct 2015

Foswiki 1.1.9 shipped with Error.pm, Foswiki 2.0 does not. We don't set the system perl's lib paths, that's done by perl itself. What we do automatically is add foswiki/lib and "." to the front of the @INC lib path, and append foswiki/lib/CPAN/lib (no longer shipped) to the end of the lib path.

Before confirming this, could you do a couple of things for us:
  1. Find where Error.pm exists in your system. On ActiveState perl, install it with ppm, on Strawberry, install it with cpanm.
    • (All of the dependencies listed in SystemRequirements should be installed. If you are running on Windows you could help improve the documentation by adding it to the list.)
  2. Get Foswiki operational if necessary by unziping the CpanContrib into the foswiki directory.
  3. Visit FoswikiServerInformation as an admin, and report the @INC lib path here.

-- GeorgeClark - 08 Oct 2015

My bad it was just that I was missing the following modules. Then I could get configure and view to run:

-- StephaneLenclud - 08 Oct 2015

I don't see any CPAN module list in SystemRequirements. I'm denied access to PerlDependencyReport

-- StephaneLenclud - 08 Oct 2015

SystemRequirements has a list of CPAN modules and equivalent package names listed by OS. They are behind "twisties" to make the topic a bit more readable. We don't have a section for Windows servers. And the list is already repeated 4 times. I guess we need some help making this topic more useful. You are not the first person to be tripped up by it.

PerlDependencyReport reveals information about the system configuration that would be of interest to anyone probing the site. It contains versions of modules, and file system locations of where it was found. So it can only be viewed by the users also permitted to run the bin/configure script. The foswiki.org page will not be available to you, but it should be usable on your local system.

-- GeorgeClark - 08 Oct 2015

Reopening this. Clearly the documentation and dependencies tool both need some work to be clearer about what's required.

-- Main.GeorgeClark - 08 Oct 2015 - 21:15

Ok thanks, just had to click one of those links to get the modules list. I guess one of them should be opened by default to make it a little more obvious.

-- StephaneLenclud - 09 Oct 2015
 

ItemTemplate edit

Summary Foswiki should clearly report missing dependencies. Don't crash with 500 Internal Server Error.
ReportedBy ThanJay
Codebase 2.0.2, 2.0.1, 2.0.0
SVN Range
AppliesTo Engine
Component Configure
Priority Urgent
CurrentState Closed
WaitingFor
Checkins distro:b3ebab2baa48 distro:3b31eb52e2bc distro:4b424853d4c2 distro:1fc7340f4a00 distro:0987542d7058
TargetRelease patch
ReleasedIn 2.0.3
CheckinsOnBranches master
trunkCheckins
masterCheckins distro:b3ebab2baa48 distro:3b31eb52e2bc distro:4b424853d4c2 distro:1fc7340f4a00 distro:0987542d7058
ItemBranchCheckins
Release01x01Checkins
Topic revision: r13 - 16 Nov 2015, GeorgeClark - This page was cached on 24 Aug 2016 - 08:50.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License