Item12005: JSPopupPlugin breaks WYSIWYG editing

pencil
Priority: Urgent
Current State: Needs Developer
Released In: n/a
Target Release: n/a
Applies To: Extension
Component: JSPopupPlugin
Branches:
Reported By: RickMach
Waiting For:
Last Change By: GeorgeClark
I'm setting up a fresh installation of Foswiki and installed and tested plugins one by one. When I installed JSPopupPlugin (and its dependency of YahooUserInterfaceContrib), the WYSIWYG editor no longer functions. When you edit a topic, the editor screen is empty. When you go to save it, it give an error that you are about to navigate away like you used your browser back button. No changes are saved. When I disabled the plugin, the WYSIWYG editor functioned again.

-- RickMach - 19 Jul 2012

The default installation comes with JQueryPlugin and that has VarPOPUPWINDOW to use instead.

-- ArthurClemens - 19 Jul 2012

POPUPWINDOW isn't the same thing as JSPopup - I'll have to look at updating it for our JQuery reality (and my lack of YUI use)

-- SvenDowideit - 25 Jul 2012

This is all now supported by JQuery and related plugins. Marking this Needs Developer, but it probably should be closed as YUI components are obsolete.

-- GeorgeClark - 05 Jan 2018
 
Topic revision: r6 - 05 Jan 2018, GeorgeClark - This page was cached on 17 Oct 2018 - 14:07.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy