You are here: Foswiki>Tasks Web>Item11860 (02 Dec 2012, GeorgeClark)Edit Attach

Item11860: SEARCH Pager not working when zeroresults parameter passed to ViewTemplate

pencil
Priority: Urgent
Current State: Closed
Released In: 1.1.6
Target Release: patch
Applies To: Engine
Component: SEARCH
Branches: Release01x01 trunk
Reported By: PaulAlexander
Waiting For:
Last Change By: GeorgeClark
-- PaulAlexander - 14 May 2012

I have the following code in a Data ViewTemplate and the DataForm attached to the topic

%TMPL:INCLUDE{"view"}% %TMPL:DEF{"form"}%%TMPL:END% %TMPL:DEF{"content"}%

%STARTSECTION{"csv_basic"}%<literal>%SEARCH{
   "form.name='UserForm'"
   type="query" 
   web="Main"
   zeroresultsnop="Empty"
   pager="on"  
   nonoise="on"
   showpage="2"
   pagesize="10"
   header="\"Topic\",\"AlternateVersion\",\"Last Modified\"$n" format="\"https://wiki.trin.org.au/$web.$topic\",\"https://wiki.trin.org.au/bin/query/$web/$topic/topic.json\",\"$isodate\""
   footer="" }%</literal>%ENDSECTION{"csv_basic"}%


%TMPL:END%

The problem I have is, when I have the zeroresults parameter the SEARCH will only return results for page one. Passing showpage=="2" returns zero results. If I exclude zeroresults="empty" and set showpage=="2" page two of the results are returned.

note: need to test on 1.1 to make sure this is only a 1.2 trunk issue.

-- SvenDowideit - 19 May 2012

Please. After an hour with git bisect ... Please mark tests as expect failure if the fix is not ready. ex: $this->expect_failure('Item11860 needs to be fixed!'); Otherwise 2 months later, it takes a bit of research to figure out why the tests are failing.

-- GeorgeClark - 22 Aug 2012

As this test is "Expect Fail" on 1.1, and the above note says to make sure it's only a 1.2 issue, and it's an urgent task, this seems as though it should be a 1.1 release blocker.

Changing to a 1.1. blocker.

-- GeorgeClark - 07 Nov 2012

i accidentally fixed 2 different paging issues in this - as i'd written failing tests that were missing - silly me smile 2 fewer bugs.

the one actually reported to this bug is indeed now fixed in 1.1.6

-- SvenDowideit - 08 Nov 2012

 
Topic revision: r11 - 02 Dec 2012, GeorgeClark - This page was cached on 09 Dec 2016 - 03:19.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License