You are here: Foswiki>Tasks Web>Item11801 (02 Dec 2012, GeorgeClark)Edit Attach

Item11801: Unable to install foswiki 1.1.5 debian package on ubuntu 12.04 due to unmet dependency

pencil
Priority: Normal
Current State: Closed
Released In: 1.1.6
Target Release: patch
Applies To: Engine
Component: DebianPackage, Docco, code dependencies
Branches: Release01x01 trunk
Reported By: WilliamGallafent
Waiting For:
Last Change By: GeorgeClark
Hi,

Unable to install foswiki on an ubuntu 12.04 machine at the moment. The “http://fosiki.com/Foswiki_debian/” repository is present in my sources.list. Some relevant stuff follows.
# apt-get install foswiki
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 foswiki : Depends: libdigest-sha1-perl but it is not installable
E: Unable to correct problems, you have held broken packages.
# apt-cache search libdigest-sha1-perl
torrus-common - Universal front-end for Round-Robin Databases (common files)
# apt-cache show foswiki
Package: foswiki
Version: 1.1.5-1
Architecture: all
Maintainer: Sven Dowideit 
Installed-Size: 24788
Depends: perl, debconf (>= 0.5) | debconf-2.0, libnet-perl, libmime-base64-perl, rcs (>= 5.7), apache | apache2 | apache2.2, libalgorithm-diff-perl, liberror-perl, libdigest-sha1-perl, libtext-diff-perl, liblocale-maketext-lexicon-perl, libcgi-session-perl, liburi-perl, libhtml-parser-perl, libcrypt-passwdmd5-perl, libhtml-tree-perl
Suggests: libunicode-maputf8-perl, libapache-mod-perl, libapache2-mod-perl2, libapache2-mod-auth-plain
Conflicts: foswiki-autoviewtemplateplugin, foswiki-comparerevisionsaddon, foswiki-famfamfamcontrib, foswiki-historyplugin, foswiki-jqueryplugin, foswiki-ratingcontrib, foswiki-voteplugin, foswiki-zoneplugin
Replaces: foswiki-autoviewtemplateplugin, foswiki-comparerevisionsaddon, foswiki-famfamfamcontrib, foswiki-historyplugin, foswiki-jqueryplugin, foswiki-zoneplugin
Provides: foswiki-autoviewtemplateplugin, foswiki-commentplugin, foswiki-comparerevisionsaddon, foswiki-edittableplugin, foswiki-emptyplugin, foswiki-famfamfamcontrib, foswiki-historyplugin, foswiki-interwikiplugin, foswiki-jqueryplugin, foswiki-jscalendarcontrib, foswiki-mailercontrib, foswiki-patternskin, foswiki-preferencesplugin, foswiki-renderlistplugin, foswiki-slideshowplugin, foswiki-smiliesplugin, foswiki-spreadsheetplugin, foswiki-tableplugin, foswiki-tinymceplugin, foswiki-tipscontrib, foswiki-topicusermappingcontrib, foswiki-twikicompatibilityplugin, foswiki-twistyplugin, foswiki-wysiwygplugin, foswiki-zoneplugin
Priority: normal
Section: web
Filename: pool/main/f/foswiki/foswiki_1.1.5-1_all.deb
Size: 15360714
SHA256: b43b49dcc0028fdfa0afe608af42bc7b3a43647bbb8b075d78bb48fe8c75ec03
SHA1: ce05efa2e92cdde7fb344f370b859bb27777a44a
MD5sum: 78005de861f2cf3b5bf80c060de5d66e
Description: A Web Based Collaboration Platform
 Foswiki is a modern CGI-based implementation of the Wiki collaboration platform
 originally developed for OOP/Patterns collaboration.  In addition to the
 traditional Wiki feature of allowing any web browser to serve as a contributing
 client, Foswiki adds rcs-based version control and user management.

Package: foswiki
Status: deinstall ok config-files
Priority: optional
Section: web
Installed-Size: 10696
Maintainer: Sven Dowideit 
Architecture: all
Version: 1.0.10-0
Config-Version: 1.0.10-0
Depends: perl, debconf (>= 0.5) | debconf-2.0, libnet-perl, libmime-base64-perl, rcs (>= 5.7), apache | apache2 | apache2.2, libalgorithm-diff-perl, liberror-perl, libdigest-sha1-perl, libtext-diff-perl, liblocale-maketext-lexicon-perl, libcgi-session-perl, liburi-perl, libhtml-parser-perl
Suggests: libunicode-maputf8-perl, libapache-mod-perl, libapache2-mod-perl2, libapache2-mod-auth-plain
Conffiles:
 /etc/foswiki/apache.conf 3a756df59e07a401a44a1f4b56b2b38e
 /etc/foswiki/LocalSite.cfg c6cc91cc1c7587af3033a50c8a7b6f6f
 /etc/foswiki/ShorterUrl.conf 14f80cb3db923ca04dfdb137ec2a57dc
Description: A Web Based Collaboration Platform
 Foswiki is a modern CGI-based implementation of the Wiki collaboration platform
 originally developed for OOP/Patterns collaboration.  In addition to the
 traditional Wiki feature of allowing any web browser to serve as a contributing
 client, Foswiki adds rcs-based version control and user management.
-- WilliamGallafent - 27 Apr 2012

As per http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=594273 Digest::SHA1 is deprecated, and instead Digest::SHA should be used.

-- WilliamGallafent - 30 Apr 2012

Forcing the package to install while ignoring dependencies works fine with my configuration. The following indicates that a very small amount of change should be required to allow all configurations to work:

root:/var/lib/foswiki# grep -r SHA1 *
data/System/SystemRequirements.txt:| Digest::SHA | Optional | Required to use SHA1 password encoding, since Perl 5.9.3 part of core |
data/System/SystemRequirements.txt:| Digest::SHA1 | Optional | Required by the Foswiki FileCache feature |
data/System/SystemRequirements.txt:| Digest::SHA1 | =libdigest-sha1-perl= | |
data/System/SystemRequirements.txt:| Digest::SHA1 | =perl-Digest-SHA1= | |
lib/CPAN/lib/Cache/FileBackend.pm:use Digest::SHA1 qw( sha1_hex );
tools/dependencies_installer.pl:    'Digest::SHA1'              => 'libdigest-sha1-perl',

It looks to me as if this package dependency should certainly be removed, in any case. Only one call in the whole codebase!

There's more info here: http://wiki.debian.org/Teams/DebianPerlGroup/OpenTasks/Transitions/DigestSHA1ToDigestSHA

-- WilliamGallafent - 30 Apr 2012

Because apt doesn't like forced installation (wants to remove foswiki, unable to install extensions, as they depend on foswiki, which has unmet dependencies), I installed a dummy-sha1-package. Don't blame me, if this breaks anything:
# apt-get install equivs
# equivs-control libdigest-sha1-perl
change/add the following lines in the libdigest-sha1-perl file created in current dir:
Package: libdigest-sha1-perl
Version: 2.13-1
Maintainer: %YOURNAME%
Architecture: all
Description: Dummy package to make foswiki debian package install
build & install dummy package and foswiki
# equivs-build libdigest-sha1-perl
# dpkg -i libdigest-sha1-perl_2.13-1_all.deb
# apt-get install foswiki
-- HelmutEberharter - 11 May 2012

I'll be uploading a new pkg tomorrow - sorry its taken so long, I've had to rebuild my server infrastructure.

-- SvenDowideit - 18 May 2012

its a shame that Digest::SHA isn't in Perl until 5.10 - another reason to move the perl min-version for 1.2.0

-- SvenDowideit - 18 May 2012

ok, deb is up - please tell me if it fixes things for you smile

I've made fixes to the 1.1 core branch and updated the docco for 1.2.0 as well.

-- SvenDowideit - 19 May 2012

 
Topic revision: r14 - 02 Dec 2012, GeorgeClark - This page was cached on 26 Jul 2016 - 04:41.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License