cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
You are here: Foswiki>Tasks Web>Item10446 (14 Jun 2011, PaulHarvey)Edit Attach

Item10446: When a topic is created, the Add form action adds an unexisting form (wrong web reference)

pencil
Priority: Urgent
Current State: Closed
Released In: 1.1.3
Target Release: patch
Applies To: Engine
Component:
Branches:
Reported By: ArthurClemens
Waiting For:
Last Change By: PaulHarvey
When you create a new topic you can add a form to the topic, but back on the edit page the form fields won't show up.

If I have a form TestForm in Sandbox, the edit page will show Form definition: System.TestForm. Somehow the wrong web is inserted. And because the form in that web does not exist, the fields cannot be loaded.

Solution: add web reference to form list items so that the selected form does not point to System web.

-- ArthurClemens - 06 Mar 2011

You made it so that WEBFORMS can't contain fully qualified topic names to other webs. It always prefixes the BASEWEB to the form name. Fixing

-- PaulHarvey - 12 Apr 2011

Re-opened for Item10874. We'll have to fix this again, with a different solution (the form.name is allowed to contain a value that is NOT fully-qualified).

-- PaulHarvey - 14 Jun 2011
 
Topic revision: r16 - 14 Jun 2011, PaulHarvey - This page was cached on 01 May 2018 - 18:55.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License