Item10137: Upgrade guide should mention clearing browser cache

Priority: Urgent
Current State: Closed
Released In: 1.1.3
Target Release: patch
Applies To: Engine
Component:
Reported By: GuruprasadIyer
Waiting For:
Last Change By: KennethLavrsen
In IE, when I edit pages and Save I get an error message:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; MS-RTC LM 8; InfoPath.3) Timestamp: Thu, 9 Dec 2010 06:38:56 UTC

Message: 'Behaviour' is undefined Line: 109 Char: 1 Code: 0 URI: http://teamwiki/pub/System/PatternSkin/pattern.js

I am using Foswiki 1.1.2

-- GuruprasadIyer - 09 Dec 2010

This code doesn't exist in PatternSkin. Are you running from an 1.0.x upgrade? Did you accidentally overwrite the pub/System files when migrating data? Try re-installing PatternSkin

-- PaulHarvey - 09 Dec 2010

No, I reinstalled the entire wiki and haven't over-written anything.

-- GuruprasadIyer - 09 Dec 2010

http://trac.foswiki.org/browser/tags/FoswikiRelease01x01x02/PatternSkin/pub/System/PatternSkin/pattern_src.js doesn't mention behaviour anywhere.

Is the browser cache flushed? Could you attach the js file you get, to this topic?

-- PaulHarvey - 09 Dec 2010

Yes, flushing the cache fixed it! Shouldn't this be documented somewhere?

-- GuruprasadIyer - 10 Dec 2010

Yes. You're not the first. We had a couple of IRC users with similar problems. Changed the title of the bug.

-- PaulHarvey - 10 Dec 2010

The end user is not reading the upgrade guide.

So we are telling the admin to communicate this to all their users. It would be better with a technical solution to flush the cached code if it is updated

-- KennethLavrsen - 11 Dec 2010

We lack versioning on CSS and JS URIs, except for files added by JQueryPlugin. I'd like to see this fixed properly, Eg. at the moment you include some JS by doing this:

%TMPL:P{"PatternSkin/pattern"}%
which generates something like
<script src="%PUBURLPATH%/%SYSTEMWEB%/PatternSkin/pattern.js"></script>
and associated dependencies in the correct order, but would be better if it used
<script src="%PUBURLPATH%/%SYSTEMWEB%/PatternSkin/pattern.js?version={mod date}"></script>
based on the date modified on the filesystem. There's more robust techniques than this too, using etags, replacing the ?param with a /path/suffix etc. but this needs significant development.

-- PaulHarvey - 08 Jan 2011

We do need a technical fix for this, but just for now I've added a notice in the UpgradeGuide. We can create a new task for the technical fix, but I'd like to see a feature proposal.

-- PaulHarvey - 09 Jan 2011
 

ItemTemplate edit

Summary Upgrade guide should mention clearing browser cache
ReportedBy GuruprasadIyer
Codebase 1.1.2, 1.1.1, 1.1.0, trunk
SVN Range
AppliesTo Engine
Component
Priority Urgent
CurrentState Closed
WaitingFor
Checkins distro:156ca194963e distro:ee238554552e
TargetRelease patch
ReleasedIn 1.1.3
Topic revision: r12 - 16 Apr 2011, KennethLavrsen
 
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. see CopyrightStatement. Creative Commons License