This question about Using an extension: Asked

Use of uninitialized value in string eq at E:/Foswiki/Foswiki/lib/Foswiki/Engine.pm line 319

I've installed FastCGIEngineContrib successfully but can't get it to run. I'm running foswiki on Windows 2003, Apache 2.2 with mod_fastcgi, strawberry perl etc.. When i restart foswiki and attempt to access a page i recieve the following error in the apache logs

[Thu Mar 26 10:58:41 2009] [warn] FastCGI: server "E:/Foswiki/Foswiki/bin/foswiki.fcgi" (pid 2072) terminated with exit with status '0'
Use of uninitialized value in string eq at E:/Foswiki/Foswiki/lib/Foswiki/Engine.pm line 319.
[Thu Mar 26 10:58:45 2009] [warn] FastCGI: server "E:/Foswiki/Foswiki/bin/foswiki.fcgi" restarted (pid 1360)

my apache config file is as follows :

Alias /foswiki/bin/configure "E:/Foswiki/Foswiki/bin/configure"
Alias /foswiki/bin   "E:/Foswiki/Foswiki/bin/foswiki.fcgi"

# Commenting the next line makes foswiki to be a dynamic server, loaded on demand
FastCgiServer "E:/Foswiki/Foswiki/bin/foswiki.fcgi" -processes 3

<Directory  "E:/Foswiki/Foswiki/bin/">
    AllowOverride All
    Options  +ExecCGI
    Allow From All

    <Files configure>
        SetHandler cgi-script
    </Files>
    <Files foswiki.fcgi>
        SetHandler fastcgi-script
    </Files>

    AuthName "A Protected Place"
    AuthType SSPI
    SSPIAuth On
    SSPIAuthoritative On
    SSPIOfferBasic On
    SSPIOmitDomain On
    require valid-user

</Directory>

<Directory  "E:/Foswiki/Foswiki/pub/">
    AllowOverride All
    Allow From All
    #for TWikiCompatibility - or even to make 'attachment not found's more user friendly
    ErrorDocument 404 /foswiki/bin/viewfile
</Directory>


Hi IanClancy!

Thanks for using FastCGIEngineContrib and sorry on the delay to answer.

Which mod_fastcgi version are you using? Which Foswiki version? Which FastCGIEngineContrib version? Which Apache version?

-- GilmarSantosJr - 08 Apr 2009


Sorry for taking so long to get back to you. To answer your query for more info ?

Apache/2.2.11 (Win32) mod_auth_sspi/1.0.4 mod_fastcgi/mod_fastcgi-SNAP-0811090952

-- IanClancy - 30 Oct 2009

Try to disable SSPIAuth and test. Then check the last comment on Tasks/Item1315.

-- GilmarSantosJr - 24 Nov 2009

QuestionForm edit

Subject Using an extension
Extension FastCGIEngineContrib
Version Foswiki 1.0.7
Status Asked
Topic revision: r6 - 24 Nov 2009, GilmarSantosJr - This page was cached on 22 Jun 2019 - 16:30.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy