cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Installation of Foswiki: Answered

Error: CGI 3.05 installed. Version 3.15 required for base Foswiki

I've just installed Foswiki 1.1.2 on our system, and I must say it's a very impressive-looking upgrade from the half-broken 1.0.9 that we ran until now. But I do have one error in configure:

configure section Web Server Environment reports:

ALERT! Error: 3.05 installed. Version 3.15 required for base Foswiki (Versions 2.89, 3.37, 3.43, and 3.47 must be avoided. Most version from 3.15 and onwards should work)

Oddly, the wiki seems to run just fine?! Because I'm such a perfectionist, I wanted to clean this up anyway, and here's what I did:

This machine has no Internet access because it's behind a serious intranet firewall, so I can't easily get updates. But with the help of Google I managed to download CGI v3.50 from here and install that into foswiki/lib/CPAN/lib/.

When I had installed this version, configure still had the above complaint as well and the section Security and Authentication complained that there was no Perl installed:

ALERT! Error: The CGI::Session Perl module is required for session support, but is not available.

- so I rolled back to v3.05 again and now I'm posting here. Apparently I need a version of CGI that contains Perl?

How do I solve the configure Error: 3.05 installed. Version 3.15 required for base Foswiki ?

You need a recent version of CGI (which you have downloaded). If you do not upgrade CGI, you will run into mysterious errors that will have you pulling your hair out by the roots (most Foswiki devs are bald for a reason)

You also need the CGI::Session module for session support. The complaint is not about Perl (which must be installed for it to run this far) but about CGI::Session.

-- CrawfordCurrie - 22 Jan 2012


Note also that installing CPAN modules into the Foswiki lib/CPAN/lib directory does not override system provided modules. The modules Foswiki ships by default are "last resort". You can change that behavior by creating or editing the bin/LocalLib.cfg file (copy from bin/LocalLib.cfg.txt)

And prior to Foswiki 1.1.4, there is a bug in configure where it loads CGI before setting the modified env. path. (Only configure, not in the rest of Foswiki). Configure will always find the default system CGI and warn, even if you've provided a local version using LocalLib.cfg. Foswiki 1.1.4 corrects that issue for configure.

-- GeorgeClark - 22 Jan 2012


Thank you Crawford and George! I think I now know what to do smile

-- TorbenGB - 22 Jan 2012

QuestionForm edit

Subject Installation of Foswiki
Extension
Version Foswiki 1.1.2
Status Answered
Related Topics
Topic revision: r4 - 22 Jan 2012, TorbenGB - This page was cached on 15 Aug 2018 - 20:34.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy