This question about Using an extension: Asked

FULLCALENDAR does not render/show anything

Hello,

I recently installed the FULLCALENDAR plugin and have the proble that it does not render anything. The page includes a call to

%FULLCALENDAR{}%

If I visit the page, there is just whitespace. So at least it looks like the macro is recognized.

I installed the plugin using the configure page. The plugins FullCalendarPlugin, ObjectPlugin, HijaxPlugin, FlexWebListPlugin and JQueryPlugin are installed and enabled. I installed the missing perl modules Date::Calc, JSON, JSON::XS, Time::ParseDate and double checked that they are displayed in "perldoc perllocal".

I first tried the plugin with Foswiki 1.1.6 and it did not work. So I upgraded to 1.1.8 to exclude any bugs, no difference.

There are no entires added to "working/logs/error.log" if I visit the page. Before a dependency was missing and there were entries added. Now it seems to be clean.

As I understood from the plugin description it is enough to install everything and call FullCalendar without parameters to show up a simple calendar.

Is there anything I forgot or overread?

-- LarsPFoswiki - 31 Oct 2013

I started a deeper examination of the problem by debugging it with firebug. Firebug reported an missing function in hijax.js: "foswiki.HijaxPluginConfigurableInit is not a function" in line 746.

I had no idea what to do about that so I just tried to re-install the HijaxPlugin. The re-installation was successfull and after going to the page with the call to FullCalendar again I finally saw the calendar. An error message poped up saying "ATTENTION: INSTANTIATE".

I found that the "INSTANTIATE" problem was posted before and fixed it following the instructions under http://foswiki.org/Support/Question863.

The initial problem seemed to be caused by the initial installation of the plugin. The automatic installation of the dependencies HijaxPlugin, ObjectPlugin and FlexWebListPlugin looks to be not 100% OK. These plugins showed an empty link under InstalledPlugins. After re-install the link of the plugins did point to existing topics. For completion I have to mention that before re-installation of the plugins I again found a premature END statement in LocalSite.cfg.

The end of the file was showing these lines:

__END__

$Foswiki::cfg{ForceDefaultUrlHost} = 0; $Foswiki::cfg{Register}{ExpireAfter} = 21600; $Foswiki::cfg{Plugins}{PatchFoswikiContribPlugin}{Module} = 'Foswiki::Plugins::PatchFoswikiContribPlugin'; 1;

Before re-installation I moved the __END__ statement at the end of the file. But now the file again looks like above. But the re-installation was succesfull and the calendar works. So the __END__ statement does not seem to be part of this problem.

-- LarsPFoswiki - 01 Nov 2013
 

QuestionForm edit

Subject Using an extension
Extension FullCalendarPlugin
Version Foswiki 1.1.8
Status Asked
Related Topics
Topic revision: r2 - 01 Nov 2013, LarsPFoswiki - This page was cached on 18 Oct 2018 - 05:46.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy