This question about Using an extension, LDAP: Answered

Cannot subscribe to topics when using LdapContrib / Subscribe

I get the following error whenever I try to subscribe to a topic using an LDAP user. I can subscribe without issue using a normal Foswiki user:

Error: ERROR: (500) Internal server error - Undefined subroutine &Foswiki::Contrib::MailerContrib::isSubscribedTo called at /var/www/foswiki/lib/Foswiki/Plugins/SubscribePlugin.pm line 149.
at /var/www/foswiki/lib/Foswiki/Plugins/SubscribePlugin.pm line 149.
Foswiki::Plugins::SubscribePlugin::_rest_subscribe('Foswiki=HASH(0x20c8ea8)', 'SubscribePlugin', 'subscribe', 'Foswiki::Response=HASH(0x20c8fe0)') called at /var/www/foswiki/lib/Foswiki/Func.pm line 768
Foswiki::Func::__ANON__('Foswiki=HASH(0x20c8ea8)', 'SubscribePlugin', 'subscribe', 'Foswiki::Response=HASH(0x20c8fe0)') called at /var/www/foswiki/lib/Foswiki/UI/Rest.pm line 280
Foswiki::UI::Rest::__ANON__() called at /usr/share/perl5/vendor_perl/Error.pm line 419
eval {...} called at /usr/share/perl5/vendor_perl/Error.pm line 411
Error::subs::try('CODE(0x327d4a0)', 'HASH(0x3286260)') called at /var/www/foswiki/lib/Foswiki/UI/Rest.pm line 295
Foswiki::UI::Rest::rest('Foswiki=HASH(0x20c8ea8)') called at /var/www/foswiki/lib/Foswiki/UI.pm line 374
Foswiki::UI::__ANON__() called at /usr/share/perl5/vendor_perl/Error.pm line 419
eval {...} called at /usr/share/perl5/vendor_perl/Error.pm line 411
Error::subs::try('CODE(0x11ce060)', 'HASH(0x20c8968)') called at /var/www/foswiki/lib/Foswiki/UI.pm line 500
Foswiki::UI::_execute('Foswiki::Request=HASH(0x209f198)', 'CODE(0x2124ff8)', 'rest', 1) called at /var/www/foswiki/lib/Foswiki/UI.pm line 326
Foswiki::UI::handleRequest('Foswiki::Request=HASH(0x209f198)') called at /var/www/foswiki/lib/Foswiki/Engine/CGI.pm line 100
Foswiki::Engine::CGI::run('Foswiki::Engine::CGI=HASH(0x19f1968)') called at /var/www/foswiki/bin/rest line 31.

Any Ideas how to get this to work?

-- PaulRinaldi - 26 Oct 2017

Doesn't seem to be related to LdapContrib.

SubscribePlugin seems to be using an API of MailerContrib ... which doesn't exist. Seems as if these two plugins aren't compatible in the versions you've got installed. Please check for updates of these two.

-- MichaelDaum - 27 Oct 2017
 

QuestionForm edit

Subject Using an extension, LDAP
Extension MailerContrib, SubscribePlugin
Version Foswiki 2.1.4
Status Answered
Related Topics
Topic revision: r2 - 27 Oct 2017, MichaelDaum - This page was cached on 15 Jan 2018 - 14:07.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License