This question about Using an extension: Answered

javascript alert: tinymce could not initialize

When I try to 'Edit' any topic, following message is displayed:

TinyMCE issue.png
When I click on 'Edit' message above is displayed. Message is not displayed when I use 'Edit wiki text' link.

To be honest, when I click on 'OK' everything seems properly - all TinyMCE icons are displayed.

No idea if this is the reason, but following error message is contained in my log file:

[Mon Jul 20 11:33:08 2015] [error] [client IP-Adress] [Mon Jul 20 11:33:08 2015] view: Use of uninitialized value in string eq at /var/www/foswiki/lib/Foswiki/Users/TopicUserMapping.pm line 572., referer: http://my-site/foswiki/bin/view/myWeb/myPage

I use LDAP authentication.

-- MateuszKDzior - 20 Jul 2015

Did you do a completely new install of Foswiki 2.0, and then migrate only the data webs (ie NOT the System web). This seems like the system is using a mix of old and new javascript files and settings.

-- GeorgeClark - 20 Jul 2015

Yes, I've done completely new install. However, since I have some pages created in Main web, I also migrated Main web:

sudo perl -I lib tools/bulk_copy.pl --iweb Main OldWiki/bin NewWiki/bin

and Sandbox as well
sudo perl -I lib tools/bulk_copy.pl --iweb Sandbox OldWiki/bin NewWiki/bin

Does it mean that topics in 'System' has been also migrated?

-- MateuszKDzior - 20 Jul 2015

It should not have. if you used --iweb, then that's the only web it should copy .

Note that the released buk_copy has some issues handling attachments. We are working hard on a new version to ship with 2.0.1

-- GeorgeClark - 20 Jul 2015

Yes, I noticed attachments issue. However, I copied manually content of 'pub' folder and they seems to be displayed correctly in most topics.

Anyway, could you tell me how should I fix my installation? Just unpack 'original' (from Foswiki 2.0 tar.gz archive) System web and overwrite all files? And after that, fix permissions?

-- MateuszKDzior - 21 Jul 2015

Just to clarify - I used bulk_copy without specifying any webs. Than, I used bulk_copy to migrate 'Sandbox' and 'Main' webs.

If i do not specify web, is it a chance that it migrated 'System' web as well?

-- MateuszKDzior - 21 Jul 2015

Yes. This is probably what has messed up your system. I'd recommend that you unpack the original 2.0 tgz archive, and restore the System directory. Might also want to restore _default and _empty just in case.

-- GeorgeClark - 21 Jul 2015

Yes, you're right. I needed to restore content of both:
  • pub/System
  • data/System
as well as refresh web browser cache (CTRL + F5).

-- MateuszKDzior - 27 Jul 2015

 

QuestionForm edit

Subject Using an extension
Extension TinyMCEPlugin
Version Foswiki 2.0.0
Status Answered
Related Topics
Topic revision: r16 - 09 Sep 2015, MichaelDaum - This page was cached on 18 May 2017 - 04:21.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License