This question about Using an extension: Answered

ClassificationPlugin dependency problem

-- MatthiasMNch - 04 Dec 2014

Hello!

we have a problem using this ClassificationPlugin:

The required Version of JQueryPlugin is not available anywhere!

Can anybody please tell me what to do?
===== INSTALLED =======
Foswiki::Contrib::JSTreeContrib version 1.04 loaded

Foswiki::Contrib::WikiWorkbenchContrib version 1.40 loaded

Foswiki::Plugins::DBCachePlugin version 6.00 loaded

Foswiki::Plugins::FilterPlugin version 4.01 loaded

Foswiki::Plugins::FlexFormPlugin version 3.10 loaded

Foswiki::Plugins::MoreFormfieldsPlugin version 0.11 loaded

Foswiki::Plugins::NatEditPlugin version 07 Aug 2013 loaded

Foswiki::Plugins::RenderPlugin version 3.22 loaded


====== MISSING ========
Foswiki::Contrib::NatSkin version >= 4.00 required
 -- installed version is 3.99_016
 -- Description: Optional
 -- Optional dependency will not be automatically installed

Foswiki::Plugins::JQueryPlugin version >= 5.10 required
 -- installed version is 4.91
 -- Description: Required

See http://foswiki.org/Extensions/Testing/WebHome

-- MichaelDaum - 04 Dec 2014

Hello!

After some research i installed the new plugin manually on the command-line (our web was telling us 4.9.x is the actual available version) and it finally worked! Thx!!

after creating a new web with the classification template the webleftbar is gone... can you tell me how i can fix this?

and it seems that some other extension is missing for this Plugin.

____ Tags %SOLRSEARCH{ "" id="solrtagcloud1" sort="date desc" type="dismax" fields="" web="ITwithKategorien" filter="type:topic web:ITwithKategorien %SOLRSEARCH{"" sort="date desc" type="dismax" fields="id" web="ITwithKategorien" filter="type:topic web:ITwithKategorien " rows="100" format="$id" separator=" OR " header="id:(" footer=")" }%" facets="tag" facetlimit="100" rows="30" }% %TAGCLOUD{ terms="%SOLRFORMAT{ "solrtagcloud1" format_tag="$key:$count" separator_tag=", " }%" header=" " format="$term" footer=" " group="$group " split="\s*,\s*" buckets="25" offset="13" warn="off" min="0" }%

Recent changes TestTopic %REDDOT{"ITwithKategorien.TestTopic"}% just to have at least some data in this web 05 Dec 2014 - 07:58 | WikiAdmin | Test Category | test

________

so i tried to install the solarsearch plugin... also with some dependency problems...

how can i add the perl and cpan modules?!?!

Can you help me out with that?

Dependency Report for SolrPlugin:

= INSTALLED ===== Foswiki::Plugins::AutoTemplatePlugin version 3.00 loaded

Foswiki::Plugins::ClassificationPlugin version 3.99_002 loaded

Foswiki::Plugins::DBCachePlugin version 6.00 loaded

Foswiki::Plugins::FilterPlugin version 4.01 loaded

Foswiki::Plugins::ImagePlugin version 5.00 loaded

Foswiki::Plugins::MimeIconPlugin version 1.20 loaded

Foswiki::Plugins::FlexWebListPlugin version 1.92 loaded

JSON::XS version 2.32 loaded

LWP::UserAgent version 6.03 loaded

HTML::Entities version 3.69 loaded

== MISSING ==== Foswiki::Contrib::InfiniteScrollContrib version >=1.0 required -- perl module is not installed -- Description: Optional -- Optional dependency will not be automatically installed

Foswiki::Contrib::JQMomentContrib version >=1.0 required -- perl module is not installed -- Description: Required

Foswiki::Contrib::JQPrettyPhotoContrib version >=1.0 required -- perl module is not installed -- Description: Required

Foswiki::Contrib::JQSerialPagerContrib version >=1.0 required -- perl module is not installed -- Description: Required

Foswiki::Contrib::JQTwistyContrib version >=1.0 required -- perl module is not installed -- Description: Required

Foswiki::Contrib::StringifierContrib version >=1.20 required -- perl module is not installed -- Description: Required

Foswiki::Plugins::TagCloudPlugin version >=1.0 required -- perl module is not installed -- Description: Required

Any::Moose version >=0.17 required -- cpan module is not installed -- Description: Required

XML::Easy version >0 required -- cpan module is not installed -- Description: Required

File::MMagic version >0 required -- cpan module is not installed -- Description: Required

DBI version >=1 required -- cpan module is not installed -- Description: Required

-- MatthiasMNch - 05 Dec 2014

somebody? any help?!?!

-- MatthiasMNch - 15 Dec 2014

SolrPlugin requires more than just the perl modules. It requires installing Solr server. (See SolrPlugin for more information on this.) If you disable SolrPlugin, ClassificationPlugin should still work ok. If not, please submit a new support question outlining specifically what's not working.

-- LynnwoodBrown - 10 Jan 2015

 

QuestionForm edit

Subject Using an extension
Extension ClassificationPlugin, JQueryPlugin, NatSkin, SolrPlugin
Version Foswiki 1.1.9
Status Answered
Related Topics
Topic revision: r6 - 10 Jan 2015, LynnwoodBrown - This page was cached on 08 Apr 2017 - 04:51.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License