This question about Configuration: Answered

Missing dependencies on FreeBSD and FCGI

When I tried installing EditChapterPlugin I observed "Validating" dialog and nothing poped after that. I made several attempts with the same result.

I found no sign of error messages in working/logs directory.

Then I checked nginx error log and found the following:
2016/01/24 07:31:02 [error] 861#0: *20696 FastCGI sent in stderr: "Can't locate object method "_platform_check_size" via package "Foswiki::Engine::FastCGI::ProcManager" at /usr/local/www/wiki.horse.private/webroot/lib/FCGI/ProcManager/Constrained.pm line 102" while reading response header from upstream, client: 24.16.xxx.xxx, server: wiki.--.com, request: "POST /bin/jsonrpc/configure HTTP/1.1", upstream: "fastcgi://192.168.3.13:9001", host: "wiki.--.com", referrer: "http://wiki.--.com/bin/configure"

As I was looking through things I tried yet another time and suddenly it all worked. I have not done anything special, no system reconfiguration of any kind. I don't think I even restarted the foswiki service.

So, I think the error I saw was the real error (I see it repeated around 4 times, which is about the numbe of times I tried to install the plugin).

My installation is on FreeBSD 10.2. The sytem is nstalled inside a FreeBSD jail and it is the only service running. I can produce any additional data you may want to see.

I just updated to latest foswiki. It is my personal wiki, so I don't know much about how to manage it.

Thank you

-- SergeiG - 24 Jan 2016

I've got another log error:

Use of uninitialized value $params[2] in join or string at /usr/local/www/wiki.horse.private/webroot/lib/Foswiki/Contrib/DbiContrib.pm line 228.

ERROR
do(INSERT INTO UserItemTag (user_id, item_id, tag_id) VALUES (?,?,?) : --) : No such file or directory : (Can't locate object method "_platform_check_size" via package "Foswiki::" while reading response header from upstream, client: 198.182.9.--, server: wiki.--.com, request: "POST /bin/save HTTP/1.1", upstream: "fastcgi://192.168.3.13:9001", host: "wiki.--.com", referrer: "http://wiki.--.com/bin/edit/Main/WebHome?t=1453744098"

-- SergeiG - 25 Jan 2016

It appears that error occurs in module responsible for extracting memory limit from Apache. I am running under Nginx. Constrained.pm documentation comment:

Subclass of L which adds checks for memory limits like L.

-- SergeiG - 25 Jan 2016

I found that I was missing BSD::Resource CPAN module. I installed it with

pkg install p5-BSD-Resource

-- SergeiG - 25 Jan 2016

Thanks for the point-out of the missing module. We had not run into that before. The SystemRequirements document has been updated for the upcoming Foswiki 2.1.

-- GeorgeClark - 29 Jan 2016
 

QuestionForm edit

Subject Configuration
Extension
Version Foswiki 2.0.3
Status Answered
Related Topics
Topic revision: r5 - 29 Jan 2016, GeorgeClark - This page was cached on 26 Sep 2017 - 06:53.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License