This question about Installation of Foswiki, Configuration, Not sure...: Answered

Checker.pm line 319 Error

Argument "5.9.0" isn't numeric in numeric lt (<) at /var/www/html/foswiki/lib/Foswiki/Configure/Checker.pm line 319.

Is the exact error im getting. I had to fix several .pm file errors but this one im at a loss. I used to program VB and yes it looks like below that they are trying to take a string and treat it like a number and that is where the error is at. 319 is the first line.


if ( $version =~ /^\d/ && $version < $rcsverRequired ) {

# RCS too old
$err .=
$prog
. ' is too old, upgrade to version '
. $rcsverRequired
. ' or higher.';
}
}
if ($err) {
$mess .= $this->ERROR(
$err . <<HERE

-- JoeRivera - 25 Sep 2015

Your system must have a recently updated RCS. RCS changed from a simple decimal version to a major.minor.patch style version, so when we extract the version, it's no longer a number. You can just comment out that whole block of code. This is fixed in the new Foswiki 2.0

-- GeorgeClark - 25 Sep 2015

 

QuestionForm edit

Subject Installation of Foswiki, Configuration, Not sure...
Extension
Version
Status Answered
Related Topics
Topic revision: r2 - 25 Sep 2015, GeorgeClark - This page was cached on 16 Feb 2017 - 18:08.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License