You are here: Foswiki>Tasks Web>Item9896 (26 Oct 2010, SvenDowideit)Edit Attach

Item9896: add compatibility with Foswiki:Extensions.JQueryPlugin when jquery-1.4.2 is selected, with fallback when required

pencil
Priority: Normal
Current State: New
Released In: n/a
Target Release: n/a
Applies To: Extension
Component: WikiDrawPlugin
Branches:
Reported By: SvenDowideit
Waiting For: Main.SvenDowideit
Last Change By: SvenDowideit
WikiDraw disables JQueryPlugin's JQUERYPLUGIN zone only for editing the svg. I've migrated the template to use zones and require, and made it possible to use JQueryPlugin's 1.4.2, but it will continue to use its own if that is not the selected JQueryVersion.

-- SvenDowideit - 26 Oct 2010

Been testing jquery-1.4.2 in Foswiki for quite some time now. Everything has been ported to 1.4.x. See Item9739. Will remove jquery-1.2.6 soon and add 1.4.3. So this hassle will go away soon.

-- MichaelDaum - 26 Oct 2010

not really. the hassle will simply move to a different version. What we really need is a require that can include a version.

-- SvenDowideit - 26 Oct 2010
 

ItemTemplate edit

Summary add compatibility with Foswiki:Extensions.JQueryPlugin when jquery-1.4.2 is selected, with fallback when required
ReportedBy SvenDowideit
Codebase
SVN Range
AppliesTo Extension
Component WikiDrawPlugin
Priority Normal
CurrentState New
WaitingFor SvenDowideit
Checkins WikiDrawPlugin:93b82c50e959
TargetRelease n/a
ReleasedIn n/a
Topic revision: r4 - 26 Oct 2010, SvenDowideit - This page was cached on 03 Mar 2021 - 07:14.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy