You are here: Foswiki>Tasks Web>Item9701 (08 Jun 2015, PaulHarvey)Edit Attach

Item9701: Scream loudly that mod_fastcgi bad, mod_fcgid good

Priority: Normal
Current State: Closed
Released In: n/a
Target Release: n/a
Applies To: Extension
Component: FastCGIEngineContrib
Branches: master
Reported By: PaulHarvey
Waiting For:
Last Change By: PaulHarvey
As per:

It seems that mod_fastcgi hasn't had any updates since 2007. As a project it seems it was absorbed into apache itself and has been shipped as a standard part of the distribution for a long time now as mod_fcgid.

We need to make this obvious to users that if you're using mod_fastcgi instead of mod_fcgid, you're probably doing things the hard way.

-- PaulHarvey - 17 Sep 2010

Actually, the two projects are vastly different; codebase, license, etc. Completed a modest doc update, closing.

-- PaulHarvey - 17 Sep 2010

I had great trouble with mod_fcgid on Windows, eventually switched to mod_fastcgi and everything works fine.

When mod_fcgid becomes part of Apache distribution, and works out the box on Windows, then I'd happily drop mod_fastcgi. No point supporting more alternatives than necessary.

-- JulianLevens - 17 Sep 2010

ItemTemplate edit

Summary Scream loudly that mod_fastcgi bad, mod_fcgid good
ReportedBy PaulHarvey
Codebase trunk
SVN Range
AppliesTo Extension
Component FastCGIEngineContrib
Priority Normal
CurrentState Closed
Checkins FastCGIEngineContrib:5f70f2c5d93e distro:10d2d88946d6
TargetRelease n/a
ReleasedIn n/a
CheckinsOnBranches master
masterCheckins distro:10d2d88946d6
Topic revision: r5 - 08 Jun 2015, PaulHarvey - This page was cached on 02 Dec 2015 - 05:22. Get a fresh version here.
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License