Item15010: configure fails to accept newer rcs versions

Priority: Urgent
Current State: Closed
Released In: 2.1.7
Target Release: patch
Applies To: Extension
Component: RCSStoreContrib
Branches: Release02x01 master
Reported By: SergioNogales
Waiting For:
Last Change By: MichaelDaum
Since I updated rcs to 5.10 in my OS i keep on getting these messages in configure:

rcs 5.10.0 detected. rcs is too old, upgrade to version 5.7 or higher. Foswiki will probably not work with this RCS setup. Either correct the setup, or switch to RcsLite. To enable RCSLite you need to change the setting of {Store}{Implementation} to 'Foswiki::Store::RcsLite'.

-- SergioNogales - 19 Jan 2021

Confirmed: the way versions are compared is broken. It compares 5.10 against 5.7 numerically and then 5.10 is lower than 5.7. Please try attached hotfix. There might be more code that does it wrong ... checking.

-- MichaelDaum - 24 Jan 2021

thankx for the hotfix, it works. Make me know if you need any additional tests/info

-- SergioNogales - 25 Jan 2021

I think that nailed it. Just some unit tests that still need fixing ...

-- MichaelDaum - 26 Jan 2021
Topic revision: r6 - 28 Mar 2022, MichaelDaum
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy