You are here: Foswiki>Tasks Web>Item14309 (18 Feb 2017, GeorgeClark)Edit Attach

Item14309: Old SVN based extensions don't compare as older than new Decimal versioned extensions

pencil
Priority: Urgent
Current State: Closed
Released In: 2.1.3
Target Release: patch
Applies To: Engine
Component: Configure
Branches: Release02x01 master Item14288
Reported By: GeorgeClark
Waiting For:
Last Change By: GeorgeClark
Configure always uses VERSION as the authority when comparing.

This was detected when the PublishPlugin was updated.

  • Installed: VERSION: $Rev: 15237 (2012-07-31) $ RELEASE: 2.4.1
  • New Extension: VERSION: 2.50, RELEASE: 25 Jan 2017

Configure was comparing 2.50 to $Rev: 15237 (2012-07-31) $ which was not being detected as an update.

Added an exception to Dependency.pm, If the installed version is a svn string, and the requested version is a "tuple", but a dotted number, and not a simple integer, then report it as needing update.

Also add to the unit tests.

-- GeorgeClark - 26 Jan 2017

 

ItemTemplate edit

Summary Old SVN based extensions don't compare as older than new Decimal versioned extensions
ReportedBy GeorgeClark
Codebase 2.1.3 beta2, 2.1.3 beta1, 2.1.2
SVN Range
AppliesTo Engine
Component Configure
Priority Urgent
CurrentState Closed
WaitingFor
Checkins distro:d3079655bd5d
TargetRelease patch
ReleasedIn 2.1.3
CheckinsOnBranches Release02x01 master Item14288
trunkCheckins
masterCheckins distro:d3079655bd5d
ItemBranchCheckins distro:d3079655bd5d
Release02x01Checkins distro:d3079655bd5d
Release02x00Checkins
Release01x01Checkins
Topic revision: r3 - 18 Feb 2017, GeorgeClark - This page was cached on 03 Jun 2017 - 16:30.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License