Item13339: Warning or errors icons in configure get stuck unless page is reloaded.

pencil
Priority: Normal
Current State: Closed
Released In: 2.1.4
Target Release: patch
Applies To: Engine
Component: Configure
Branches: master Item14288 Release02x01 Item14380 Item14537
Reported By: RaulFRodriguez
Waiting For:
Last Change By: CrawfordCurrie
When using bin/configure script while installing Foswiki from git, and correcting or addressing each of the items marked with warning or error exclamation marks icons, these icons stay there through the cause for them has been addressed.

For instance, the following menu items and tabs were showing and not removing the icons (probably not limited to these though):

  • Security and Authentication
  • Store
  • Mail

You need to reload the page to see them go away.

This can be reproduced this way:

  • go to bin/configure
  • click on "Mail" in the left menu
  • in the tab "Basic settings & Auto-configure", remove the "Webmaster Email" and save the change
  • an icon appears in the left menu and in the tab, and a message complaining that the address is needed
  • fill-in the address and update the configuration
  • the page does not complain anymore that the e-mail address is missing, but the icon still appears in the left menu and in the tab

-- RaulFRodriguez - 27 Mar 2015

Fix could be cherry-picked for the next patch if it's wanted; but it's just cosmetic, so low value.

-- Main.CrawfordCurrie - 27 Apr 2017 - 09:32

 
Topic revision: r10 - 31 Jan 2018, CrawfordCurrie - This page was cached on 16 Jan 2020 - 05:13.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy