Item13266: dependencies_installer.pl uses deprecated cpanplus, and is out of date

pencil
Priority: Normal
Current State: Needs Developer
Released In: n/a
Target Release: minor
Applies To: Engine
Component: FoswikiTools
Branches:
Reported By: GeorgeClark
Waiting For:
Last Change By: GeorgeClark
CPANPLUS has been deprecated in perl 5.18, and is removed from perl 5.20, along with all modules that are used only by that tool Approximately 14 dependencies removed from perl core according to the discussion lists.

So this tool is pretty much toast. A dependencies installer that has 14 missing dependencies is not helpful.

Needs to be rewritten, or removed from 1.2. Marking urgent.

-- GeorgeClark - 18 Feb 2015

Removed from 1.2, but leaving the task open. However no longer needs to be urgent.

-- GeorgeClark - 23 Feb 2015
 

ItemTemplate edit

Summary dependencies_installer.pl uses deprecated cpanplus, and is out of date
ReportedBy GeorgeClark
Codebase trunk
SVN Range
AppliesTo Engine
Component FoswikiTools
Priority Normal
CurrentState Needs Developer
WaitingFor
Checkins
TargetRelease minor
ReleasedIn n/a
CheckinsOnBranches
trunkCheckins
masterCheckins
ItemBranchCheckins
Release01x01Checkins
Topic revision: r4 - 17 Aug 2015, GeorgeClark - This page was cached on 27 Jan 2021 - 11:40.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy