Item13206: Upgrade to latest jquery-ui.

pencil
Priority: Urgent
Current State: Closed
Released In: 2.1.3
Target Release: patch
Applies To: Extension
Component: JQueryPlugin
Branches: master Item13897 Release02x01 Item14152
Reported By: MichaelDaum
Waiting For:
Last Change By: GeorgeClark
This one is more challenging and probably out of scope for Foswiki 1.2.0 ante portas as it might cause problems in other javascript code. See the migration guide at http://jqueryui.com/upgrade-guide/1.11/ for a mild shock...

-- MichaelDaum - 12 Jan 2015

Marking Post 2.0, and Proposal Required. Sounds like complex migration needs more consideration than a task.

-- Main.GeorgeClark - 06 Jul 2015 - 03:28

There is nothing to propose, just keeping up with 3rd party jQuery components.

-- MichaelDaum - 06 Jul 2015

Pushing out to 2.2.

-- Main.GeorgeClark - 19 Dec 2015

jquery-ui is now packaged as one monolithic javascript file. For now we shipped all components loadable individually. This doesn't seem to be supported upstream anymore. As such I'll have to restructure (and simplify) the way we ship jquery-ui as well, i.e. move it from pub/System/JQueryPlugin/ui and pub/System/JQueryPlugin/themes to the pub/System/JQueryPlugin/plugins area, as are all jquery modules.

Also: according to the upgrade guide support for IE8, IE9, and IE10 is discontinued, means still works but isn't tested nor supported upstream anymore.

-- MichaelDaum - 25 Jul 2016
 
Topic revision: r18 - 18 Feb 2017, GeorgeClark - This page was cached on 01 Jun 2017 - 07:52.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License