You are here: Foswiki>Tasks Web>Item13139 (01 Jul 2015, GeorgeClark)Edit Attach

Item13139: Backwards compatibility issues with Foswiki 1.2 default extensions

pencil
Priority: Urgent
Current State: Closed
Released In: n/a
Target Release: n/a
Applies To: Engine
Component: EditRowPlugin, TinyMCEPlugin
Branches: master
Reported By: GeorgeClark
Waiting For:
Last Change By: GeorgeClark
We can't release 1.2 default extensions until they are backwards compatible with Foswiki 1.1. Please add to this list and DONE them off once fixed.

  • TinyMCEPlugin appears to require JQuery 6+. Not listed in dependencies DONE
  • EditRowPlugin dependent upon Foswiki 1.2 Foswiki::Request::multi_param()
    • Monkey patches in place for this and Foswiki::Render::html as well
  • TablesContrib appears to be dependent on Foswiki::Attrs::findFirstOccurenceAttrs() DONE
  • JsonRpcContrib dependent upon Foswiki 1.2 =Foswiki::Request::multi_param()= DONE

-- GeorgeClark - 11 Dec 2014

Marked "being worked on" as you appear to be working on it.

-- CrawfordCurrie - 15 Dec 2014

Set back to Confirmed. Someone needs to test all the 1.2 extensions on 1.1.9 before we actually make the final release and upload all the extensions.

-- GeorgeClark - 20 Apr 2015

I've installed most of the 1.2 extensions on 1.1.9, and found a couple of problems.
  • SubscribePlugin generates invalid links for the Subscribe button.
  • When famfamfam skin is added, it generates a link that triggers a 403 invalid validation code error.

The TinyMCEPlugin won't install on 1.1.9 from the .tgz file, at least with older versions of cpan modules. Archive::Tar seems to have trouble with long filenames, and attempts to extract the @LongLink trigger name that is set in the archive when a filename exceeds the blocksize. The zipfile version installs fine. The following patch fixes the issue on 1.1.9, might be advisable on 1.2.0 DONE

Fixed under Item13449

-- GeorgeClark - 08 Jun 2015

1.2 PatternSkin does not work on Foswiki 1.1.9. Some sort of templating issue, top, left and bottom bars are not found.

-- GeorgeClark - 09 Jun 2015

TopicUserMappingContrib is not backwards compatible. Unable to add users to groups when installed on 1.1.9

-- GeorgeClark - 09 Jun 2015
 
Topic revision: r10 - 01 Jul 2015, GeorgeClark - This page was cached on 28 Jul 2020 - 18:53.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy