You are here: Foswiki>Tasks Web>Item12847 (14 Apr 2014, LeilaPearson)Edit Attach

Item12847: Weird blank line in WYSIWYG mode when first line is a MACRO followed by a table

pencil
Priority: Low
Current State: Confirmed
Released In: n/a
Target Release: n/a
Applies To: Extension
Component: WysiwygPlugin
Branches:
Reported By: LeilaPearson
Waiting For:
Last Change By: LeilaPearson
Create a topic that contains the following wiki text (or see EditTest10 or http://trunk.foswiki.org/Sandbox/EditTest10):
%TOPIC%
| Table | Text |

Edit that topic in WYSIWYG mode and you can see a strange blank line above the TOPIC macro.

-- LeilaPearson - 04 Apr 2014

This is done intentionally. The TinyMCE editor has issues where it's not possible to position the cursor ahead of the first element of a page, or after the last element. The Wysiwyg conversion attempts to work around this by inserting a blank line, and then removing it on save. It shows up as:
<p class="foswikiDeleteMe">&#160;</p>

Marking this as confirmed, but we probably can't fix it unless a new version of the TinyMCE editor component resolves the cursor positioning issue.

-- GeorgeClark - 08 Apr 2014

I don't see a cursor positioning problem on the demo page for TinyMCE 3.x. Looks like if we upgrade to the latest 3.x (or 4.x) we could remove this workaround.

-- LeilaPearson - 14 Apr 2014
 

ItemTemplate edit

Summary Weird blank line in WYSIWYG mode when first line is a MACRO followed by a table
ReportedBy LeilaPearson
Codebase 1.1.9, trunk
SVN Range
AppliesTo Extension
Component WysiwygPlugin
Priority Low
CurrentState Confirmed
WaitingFor
Checkins
TargetRelease n/a
ReleasedIn n/a
CheckinsOnBranches
trunkCheckins
Release01x01Checkins
Topic revision: r4 - 14 Apr 2014, LeilaPearson - This page was cached on 16 Jan 2020 - 17:21.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy