You are here: Foswiki>Tasks Web>Item11878 (05 Jul 2015, GeorgeClark)Edit Attach

Item11878: require perl 5.8.8 for 1.2.0

Priority: Enhancement
Current State: Closed
Released In: 2.0.0
Target Release: major
Applies To: Engine
Branches: trunk
Reported By: SvenDowideit
Waiting For:
Last Change By: GeorgeClark

-- SvenDowideit - 19 May 2012

Changing this to use 5.008_008. The v5.8.8 version fails on OSX Snow Leopard, which ships with perl 5.10.0.

-- GeorgeClark - 14 Nov 2012

Sven... Do we still need the "use 5.6 / require 5.008" combination, or can this just be a simple "use 5.008_008"

-- GeorgeClark - 14 Nov 2012

when i did it, i was following a recomendation that suggested that doing it this way would give the most newbie friendly errors

other than that, no idea.

-- SvenDowideit - 11 Feb 2013

I think this is now a moot point. We now require version 0.77, so perl will understand 5.8 nomenclature. The use 5.6 was to deal with really old perl, that doesn't understand the newer style version strings. "version 0.77" updates the 5.10.0 version handling.

-- GeorgeClark - 12 Feb 2013
Topic revision: r11 - 05 Jul 2015, GeorgeClark
The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License