You are here: Foswiki>Tasks Web>Item10113 (03 May 2011, AndrewJones)Edit Attach

Item10113: BibliographyPlugin not compatible with FW 1.1

pencil
Priority: Urgent
Current State: Closed
Released In: n/a
Target Release: n/a
Applies To: Extension
Component: BibliographyPlugin
Branches:
Reported By: WillNorris
Waiting For:
Last Change By: AndrewJones
Foswiki detected an internal error - please check your Foswiki logs and webserver logs for more information.

Can't locate object method "reload" via package "Foswiki::Meta"

-- WillNorris - 03 Dec 2010

or maybe it's FastCGI?

-- WillNorris - 03 Dec 2010


Index: lib/Foswiki/Plugins/BibliographyPlugin/Core.pm
===================================================================
--- lib/Foswiki/Plugins/BibliographyPlugin/Core.pm      (revision 2381)
+++ lib/Foswiki/Plugins/BibliographyPlugin/Core.pm      (working copy)
@@ -281,7 +281,7 @@
 
     if ( $Foswiki::Plugins::VERSION >= 2.1 ) {
         $topicObject = Foswiki::Meta->new( $session, $web, $topic );
-        $topicObject->reload();
+        $topicObject->load();
         if ( not $topicObject->haveAccess('VIEW') ) {
             $topicObject->finish();
             $topicObject = undef;

seems to work...

-- WillNorris - 03 Dec 2010

Oops; I've been running from trunk - the change has already been committed, but not released yet

-- PaulHarvey - 04 Dec 2010

Fixed a small typo and released.

-- AndrewJones - 03 May 2011
 
Topic revision: r3 - 03 May 2011, AndrewJones - This page was cached on 04 Jun 2020 - 05:41.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy