This question about Configuration: Answered

configure dies loading perl module CGI

I have a stable install of XAMPP running on a WinXP sp 3 box.

Walking through the install of Foswiki, I am at the 'configure' stage, but it keeps failing with the following page:

Software error:

Failed to load the perl module CGI qw(:any). The module could not be found. 

Please ensure that:
   1 CGI qw(:any) is installed,
   2 that the module is available on the @INC path,
   3 that the webserver user (SYSTEM) has permission to read the CGI qw(:any).pm file.
The detailed error seen was:
Use of uninitialized value $_ in -d at C:/xampp/perl/lib/CGI.pm line 4143.
Compilation failed in require at (eval 12) line 2.
BEGIN failed--compilation aborted at (eval 12) line 2.

Looking into CGI.pm line 4143, it is within package CGITempFile; sub find_tempdir{};

Any assistance on getting past this point so I can create the LocalSite.cfg would be greatly appreciated.

Thank you

Patrick


These types of issues are probably better debugged interactively. If you still need assistance, please join the #foswiki support channel on IRC. We can help you resolve the issue.
  • What version of CGI is installed
  • What version and distribution of perl? Strawberry, ActiveState ?

-- GeorgeClark - 27 Nov 2011

It's been a while, but as it happens, the perl project has removed CGI as a default package. So it has to be installed using cpan tools.

-- GeorgeClark - 09 Jan 2015

QuestionForm edit

Subject Configuration
Extension
Version Foswiki 1.1.3
Status Answered
Related Topics
Topic revision: r3 - 09 Jan 2015, GeorgeClark - This page was cached on 12 Jan 2018 - 20:21.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License