This question about Topic Markup Language and applications: Asked

How can I correctly create a new topic based on a template topic containing attachments?

I have a question regarding creation of a new topic based on a template topic that contains one or more attachments. Because the meta data of the template topic is also copied to the new topic, it looks like the new topic also contains the same attachments of the template topic. But when clicking on the attachment in the attachment table of the new topic, Foswiki generates an error that the attachment does not exist because the actual attachment was not copied. Removing the attachment afterwards is also not possible, because Foswiki also complains that the attachment does not exist. How can I either prevent that either the meta data of the attachments is copied or how can I ensure that the actual attachments are copied during the creation of the new topic? (Because I’m not sure if this is could be seen as I bug or not, for now I have only created this support question. I you think that this could be seen as a bug, please let me know. In that case I will create a bug request instead.)

Thank you in advance for your help, Nathan

QuestionForm edit

Subject Topic Markup Language and applications
Extension
Version Foswiki 1.0.9
Status Asked
Topic revision: r1 - 22 Mar 2011, NathanSanders - This page was cached on 04 Jun 2020 - 00:18.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy