This question about Using an extension: Answered

NatSkin does not show Web Buttons

Hi,

I try to install foswiki on our homepage to replace our old twiki. The install went fine without any bigger problems, but when i tried to use the NatSkin plugin the unusual behaviour started.

I configured the NatSkin with the NatSkinStyleBrowser and I could see every change immediately. The only thing that did not show are the Web Buttons to choose another Web. I can only see a light blue stripe from left to right. My SiteButtons, this is what i think the list of webs should come from, expand the FLEXWEBLIST to Main Sandbox System TWiki Test Trash. So it should use these to generate the buttons.

Or am i missing something here? Hopefully someone can give me a hint.

Thanks,

Markus


Hi Markus, as you can see on NatSkin, the version online isn't compatible with foswiki-1.0.x. This is work in progress on svn/trunk. Have a look at http://svn.foswiki.org/trunk/ to get a working set of plugins required to run NatSkin.

-- MichaelDaum - 20 Mar 2011


Hi Michael, i can only see the compatibility issue with the DBCachePlugin, which i have downgraded now. My installation says on the Mainpage: "This site is running Foswiki version Foswiki-1.1.2, Wed, 10 Nov 2010, build 9940, Plugin API version 2.1". The InstalledPlugin page tells me i have all needed plugins for NatSkin in a version above the minimal needed (according to the Dependencies on the NatSkin topic).

Do you mean i have to install newer plugins from the svn or do i have to use the NatSkin from the svn? Is there a way to see which plugin is used to generate the Website Buttons so i do not need to update every plugin in a trial and error process?

Thanks.

-- MarkusBajones - 21 Mar 2011


I also have the same problem, and am using Foswiki 1.0.9. , API version 2 We installed all plugins from svn manually (the install script is broken, anyway) , but the web buttons are still missing.

-- StefanosKouzof - 31 Mar 2011


I have the same problem with 1.1.3. The quick fix I found is to go to templates/body.nat.tmpl and replace the line

%TMPL:DEF{"webbuttons"}%<div class="natWebButtonsContents natWebButtonsHidden">  
with
%TMPL:DEF{"webbuttons"}%<div class="natWebButtonsContents"> 
The superfish stuff still doesn't work but at least it's better than nothing

-- JamesSpezeski - 30 Aug 2011

This question is pretty old and concerns older version of Foswiki and NatSkin. In any case, JamesSpezeski did provide a quick fix for the referenced versions, so I'm closing this question.

-- LynnwoodBrown - 06 Jan 2015

QuestionForm edit

Subject Using an extension
Extension NatSkin
Version Foswiki 1.1.2
Status Answered
Related Topics
Topic revision: r7 - 06 Jan 2015, LynnwoodBrown - This page was cached on 16 Nov 2018 - 19:50.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy