This question about Using an extension: Asked

New icon added in the table can't be used

  • I wanted to add a new icon to the SmiliesPlugin and attached two new gif-files.
  • Afterwards I added the new entry in the table for the icons - new rows with an short-text, the icon and the comment.
  • Below - with the line where the icons are displayed to test it - I added the shortcut.
Result: the shorttext of the icon is not replaced by the icon itself on this page.

I added the new icon-shorttext in any topic in the sandboxweb. There the icon is displayed sometimes. If you reload the page than 1 out of 10 times reloading the page the icon is displayed.

Update: after a weekend (nobody using the wiki) the new smilies are working! We didn't set up any caching!

Any idea?!

best regards

LuPo

Hi I just came across your Problem. Maybe you or others they have the same Problem are interestedin my Workaround for this:

I've allways update the Topic by commandline (../data/System/SmiliesPlugin.txt) and also add the Pic's by this way (../pub/System/SmiliesPlugin/). After setting the right Permissions to the changed files and do a restart of the apache webserver it just works.

Hope it helps...

-- MachsGut - 13 Feb 2020
 

QuestionForm edit

Subject Using an extension
Extension SmiliesPlugin
Version Foswiki 1.1.2
Status Asked
Related Topics
Topic revision: r3 - 13 Feb 2020, MachsGut - This page was cached on 13 Feb 2020 - 20:08.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy