This question about Using an extension: Task closed

Wrong Wiki-Names from mail Parameter

Edit: Looks like I found a solution to this: I needed to delete the Cache File: "/working/work_areas/LdapContrib/cache.db" and do a cache-refresh from within the Wiki. Just refreshing the Cache (which I did probably 100 times) did NOT work. Only after deleting the Cache-File it worked.

Still don't know WHY it did not work, but at least it is solved now.


We have two Foswiki 1.1.2 Setups on the same server (one test and one productive). This used to work without a flaw in the past. But now, after upgrading both setups to 1.1.2 we experience a strange behaviour on our Test-Setup with the Ldap-Extension.

We use to take the Users E-Mail as WikiNameAttribute. If a user with the email "oliver.schaub@..." and the login "schaub_o" is loggin in, his Name should be displayed as OliverSchaub. But it is actually displayed as "Schaub O" and a User-Topic "SchaubO" is created in the Main-Web. So it looks like Ldap-Contrib is using the LoginAttribute instead of the MailAtrribute for the WikiName... This is strange, since we use the EXACT same configuration on our Productive System.

$Foswiki::cfg{Ldap}{UserScope} = 'one';
$Foswiki::cfg{Ldap}{LoginAttribute} = 'cn';
$Foswiki::cfg{Ldap}{MailAttribute} = 'mail';
$Foswiki::cfg{Ldap}{WikiNameAttributes} = 'mail';
$Foswiki::cfg{Ldap}{NormalizeWikiNames} = 1;
$Foswiki::cfg{Ldap}{RewriteWikiNames} = {
'^(.*)@.*$' => '$1'
};
$Foswiki::cfg{Ldap}{NormalizeLoginNames} = 1;
$Foswiki::cfg{Ldap}{WikiNameAliases} = '';

I enabled debugging and got the following lines in the Apache-Error Log: LdapContrib - called getWikiNameOfLogin(schaub_o)
Shouldn't this be "getWikiNameOfMail" or something like this?

What could cause a behaviour such as this? Since it is working perfect on our Production-Setup and the Ldap-Setup is exactly similar on both Setups, I suspect some other Extension/Configuration which is somehow messing it all up.
Are there any known issues with other Extensions? What configuration besides Ldap-Configuration could have an Influence on this?

I'm going through our setup now step by step trying to figure it out... but I would be very thankful for any tip that might push me in the right direction.

Thanks a lot,

Oliver

QuestionForm edit

Subject Using an extension
Extension LdapContrib
Version Foswiki 1.1.2
Status Task closed
Topic revision: r1 - 23 Feb 2011, OliverSchaub - This page was cached on 18 Oct 2018 - 08:52.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy