This question about Configuration: Asked

FastCGILargeUploadsError

We are using, since long time, a Foswiki instance as Intranet for our company.

In the last few days (since 20 dec 2010) we are experiencing issues when uploading "large" attachments (size more than 50 Mb approx): after some waiting the page goes to time-out.

In the past we have uploaded even very large attachments (over 300 Mb) without any problem.

Examining the situation on the server (SUSE ent. desktop 9) I can notice that the attachment is correctly uploaded to the server and inserted into the right folder /pub/Webname/Pagename. Also the right ,v attachment file for versioning get generated: seems like the system hangs when inserting the META of the attachment into the page.

The only strange things I can see come from the server logs. The error_log of foswiki shows:
[warn] mod_fcgid: Read data error, fastcgi server has close connection
[error] [client 172.18.1.177] Premature end of script headers: foswiki.fcgi, referer: https://<address>/bin/attach/Sandbox/TestPage

while the warning log shows
 warning | /srv/www/htdocs/icwiki/pub/Sandbox/TestPage/trenduninstall.zip,v is corrupt; parsed up to admin.head |

and the apache2 log shows
[notice] mod_fcgid: process /srv/www/htdocs/icwiki/bin/foswiki.fcgi(32039) exit(lifetime expired), get stop signal 15
[notice] mod_fcgid: process /srv/www/htdocs/icwiki/bin/foswiki.fcgi(1467) exit(idle timeout), get stop signal 15
[notice] mod_fcgid: process /srv/www/htdocs/icwiki/bin/foswiki.fcgi(2124) exit(idle timeout), get stop signal 15
[notice] mod_fcgid: process /srv/www/htdocs/icwiki/bin/foswiki.fcgi(2145) exit(idle timeout), get stop signal 15
[Wed Jan 12 16:52:16 2011] [notice] mod_fcgid: process /srv/www/htdocs/icwiki/bin/foswiki.fcgi(2278) exit(communication error), get stop signal 15
[Wed Jan 12 16:52:16 2011] [notice] child pid 32016 exit signal Segmentation fault (11)
[Wed Jan 12 16:52:16 2011] [error] mod_fcgid: fcgid process manager died, restarting the server

In the last days no changes have been made to system configuration (apache, virtual hosts, contrib, plugins, etc). What could be the cause?

Thank you in advance for your precious support

ALERT! Note: I've tried uploading first a small attachment then clicked on "manage" and uploaded a bigger one with the same name: all seems working well.... ALERT! Note: I've also tried to raise the timeout of communication and process for the mod_fcgdi into the apache configuration file, but no luck...

-- FabrizioBerdondini - 12 Jan 2011

QuestionForm edit

Subject Configuration
Extension
Version Foswiki 1.0.9
Status Asked
Topic revision: r1 - 12 Jan 2011, FabrizioBerdondini - This page was cached on 16 Jun 2019 - 21:17.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy