This question about Using an extension: Asked

DrupalUserContrib min drupal version

The documentation for DrupalUserContrib says minumum version Drupal 6.5. The only versions available are 6.19 and 7.x. Does this mean that really it needs 7.x?

Seems to work with 6.19 but had one issue: In line 109 of DrupalLogin, it checks for defined $authuser and defined cookie. Problem is, the authuser is already set at that point to 'guest' so it ignores the cookie. My fix was to add a check for 'guest', and now it picks up the cookie:

if ( (defined($authUser) || $authUser == 'guest') and defined( $cookies{$DrupalCookieName} ) ) {

also had to comment out this line: $cookie_domain =~ s/^(\.|www\.)//; #remove leading dot (wtf) or leading www.

since my drupal was using the www to create the cookie name

Ian

QuestionForm edit

Subject Using an extension
Extension DrupalUsersContrib
Version Foswiki 1.1.2
Status Asked
Topic revision: r2 - 13 Dec 2010, IanBowles - This page was cached on 14 Dec 2019 - 19:11.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy