This question about Installation of Foswiki: Needs followup in Tasks

Modal Dialogs don't work anymore since upgrade to 1.1.2

Hello,

Since the Upgrade to Foswiki 1.1.2 from 1.0.9, we experience some Problems with NatEditPlugin.

The Editor itself seems to work fine. (Edit & save works) There were some strange issues where the "standard" Editor would load instead of NatEdit. Normally one or two Browser-Refreshes solved this and it seems to be gone away after one Day now...

But there is a great issue with the Buttons which trigger the jquery Modal-Dialog such as: Insert Link, Insert Table and Insert Attachment. The Modal Dialogs are loaded, but they do nothing. If the OK or Submit-Button is pressed, the focus simply goes back to the Editor-Window. In Firebug, three Javascript-Errors pop up (they pop up only after pressing the OK or Cancel Button in the Modal Dialogs, not on loading NatEdit):

Fehler: foswiki is not defined
Quelldatei: https://......./JavascriptFiles/foswikiPref.js
Zeile: 1
----------
Fehler: foswiki is not defined
Quelldatei: https://.....JavascriptFiles/foswiki_edit.js
Zeile: 1
----------
Fehler: foswiki is not defined
Quelldatei: https://..../PatternSkin/pattern_edit.js
Zeile: 1

Sometimes, after pressing OK or Cancel, there is even OLD content loaded into the Editor Window. As if there is some Caching-Problem. But there is nothing in the Error-Logs.

Did we miss some important settings concerning NatEdit and Jquery?

Thank you in Advance for any Help.

Oliver


NatEditPlugin needs some adjustments to the latest foswiki... filed as Tasks.Item10101.

-- MichaelDaum - 01 Dec 2010

QuestionForm edit

Subject Installation of Foswiki
Extension NatEditPlugin
Version Foswiki 1.1.2
Status Needs followup in Tasks
Topic revision: r2 - 01 Dec 2010, MichaelDaum - This page was cached on 18 Oct 2018 - 08:43.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy