cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Using an extension: Answered

Including bare JQuery library

JQSCRIPT was deprecated in the 28 Jan 2010 version of JQueryPlugin. what is now the recommend procedure for including the bare JQuery library in a page? often, i write "bare metal" JQuery code without using any of the plugins bundled with JQueryPlugin.

-- WillNorris - 09 Feb 2010

I think %JQREQUIRE{"foswiki"}% would be a minimum. You also get a few others by default (check configure).

I'm pretty sure it's just %JQREQUIRE%

-- PaulHarvey - 09 Feb 2010

Set $Foswiki::cfg{JQueryPlugin}{DefaultPlugins} = '';

This will load the jquery, and foswiki but nothing else. Only topics or skins with explicit %JQREQUIREs will load additional plugins.

If that's still too much. Then install JQueryPlugin but disable it. Then add

<script type="text/javascript" src="%PUBURLPATH%/%SYSTEMWEB%/JQueryPlugin/jquery-1.3.2.js"></script>

to your skin.

-- MichaelDaum - 09 Feb 2010

QuestionForm edit

Subject Using an extension
Extension JQueryPlugin
Version Foswiki 1.0.9
Status Answered
Topic revision: r3 - 09 Feb 2010, MichaelDaum - This page was cached on 22 Sep 2018 - 00:25.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy