This question about Installation of Foswiki: Answered

Error 500 on Strawberry install (windows)

Hello,

I am trying to install the foswiki on windows from strawberry installer, everything runs OK, and I can access my configure screen without problems, but always when I try to enter in view screen I got error 500 from apache.

I tried to find any log but I didn´t got any useful information, anyone know how to solve this problem?

I have already tried to see the apache error log, but it hasn't any message. The only message that I get is in access log and the message is:

10.198.62.220 - - [20/Jan/2009:08:44:15 -0200] "GET /foswiki/bin/view/System/WebHome HTTP/1.1" 500 490
10.198.62.220 - - [20/Jan/2009:08:44:57 -0200] "GET /foswiki/bin/view.pl/System/WebHome HTTP/1.1" 500 490

I have tried use .pl, but this didn't work too.

Thanks,

Ruy Neto
I just installed foswiki using the windows installer, that also includes apache and strawberry perl. I tested on a Win2k3, that didn't have neither apache nor strawberry perl previously installed. Everything went fine.

Be sure you have something like the following in yout httpd.conf:
ErrorLog "logs/error.log"
Apache should put details about internal server errors in the error.log... please review that.

-- GilmarSantosJr - 21 Jan 2009
Hello Gilmar,

My apache are writing logs, but aren´t writing any error log for this situation.

I use the same installer, but the only difference that I have to install foswiki in a default directory in disk D:, this directory is defined by my company, and I can´t change.

I will try to revise my apache configuration, but I didn´t have any idea where the problem could be.

Can you send the security permissions for the directories?

Thanks,

Ruy Neto
yup, there is a bug in the installer v1.0.0-1 that doesn't get the path right when you change it from the default frown, sad smile

right now I'm not 100% positive what file needs changing (I don't use windows that much at the moment), but I'm betting that either the LocalLib.cfg or LocalSite.cfg files contain references to c:\PROGRAM... - change those to point to the right place.

I'll go back an look into it this weekend - and publish a new set of isntallers.

-- SvenDowideit - 22 Jan 2009
Hello for all,

As I said I have already change every configuration, but when I was changing the paths I didn´t realized that the template path have more than one place to change de default directories, when I change all paths start to work, thanks for the help.

-- RuyNeto - 23 Jan 2009

cool wink and for future reference - I've uploaded Foswiki Windows installer v1.0.0-2 which fixes this issue.

-- SvenDowideit - 23 Jan 2009

QuestionForm edit

Subject Installation of Foswiki
Extension
Version
Status Answered
Topic revision: r11 - 07 Feb 2009, ArthurClemens - This page was cached on 14 Jan 2018 - 09:18.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License