cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Installation of Foswiki: Answered

Can't create new topics in Main, and can't copy topic in Sandbox - Apache config Redirectmatch issue

Hi! Have installed a fresh foswiki 1.0.8, and added NatSkin with all it's required plugins. I am experiencing a strange behavior: In my Main web (NatSkin) I can't create new topics: After clicking "Submit" in the create new topic form, I get a page saying "Topic 'MyNewPage' does not exists" and 3 buttons "Create new topic" "Search in all webs" "Cancel" If I click "Create new topic" I get a new button "Submit", and when I click that I am again redirected to the "Topic 'MyNewPage' does not exists" and 3 buttons!!!

So I am stuck!

The other strange behavior is that I am unable to copy a topic with the "More topic actions"/"Copy topic" for topic in my System and Sandbox web (Pattern skin). When I click the "Copy topic" I am only redirected to my Main frontpage!

I hope someone are able to help me. I have no errors in my Apache log, and permissions is set according to the installation guides.

-- AtleBriskemyr - 22 Dec 2009


Have you tried disabling NatSkin and seeing if you still have problems? That will allow us to know if its NatSkin that is causing the issues, or something with your set-up.

Also do you have any plugins installed that may also be part of the problem?

-- AndrewJones - 23 Dec 2009


I have now disabled NatSkin, and set pattern as my Main skin. Then I have the same experience as the explained above for the System web; that's

If I try to copy or create a new topic in the Main web (now running pattern skin), when I click the executing button (create or copy) I am only re-directed to the Main, with now new page created. I also tried to disable some plugins, including DBCachePlugin, but now change in behavior.

-- AtleBriskemyr - 03 Jan 2010

Are you using Shorter URLs, If so, does it work if you go back to a standard URL configuration. I seem to recall an issue where if the redirect for authentication is not quite right, you can get into some issues.

-- GeorgeClark - 18 Jan 2010

I am not using any short urls, however... I have isolated this problem to be a Apachec config issue. I had a RedirectMatch statement in my virtualhost! This was the reason for the redirect to the main webhome. When I disable the redirect statement, it is all functional properly. This is the start of my config file:
 
<VirtualHost *>
    ServerAdmin blablaAtserver
    ServerName intranet
    DocumentRoot /var/www/Foswiki-1.0.9
#    RedirectMatch permanent /$ http://intranet/bin/view/Main/WebHome

#### Change the _second_ path to match your local installation
ScriptAlias /bin "/var/www/Foswiki-1.0.9/bin"
...

The RedirectMatch above is causeing the trouble. So how can I include a proper redirect statement, I want to have users who just enter the servername intranet to be redirected to the Main/!WebHome?

-- AtleBriskemyr - 18 Jan 2010

Can you try with a straightforward Redirect on /index.html ? That works fine on all my Foswiki sites (intranet & public).

Redirect permanent /index.html http://intranet/bin/view/Main/WebHome

-- MartinRowe - 18 Jan 2010

You could also try the following - Note the ^ start-of-url character.
RedirectMatch permanent ^/$ http://intranet/bin/view/Main/WebHome

-- GeorgeClark - 18 Jan 2010

Hi! Thanks! smile The ^ start-of-url character was the missing part.

-- AtleBriskemyr - 22 Jan 2010

QuestionForm edit

Subject Installation of Foswiki
Extension
Version Foswiki 1.0.8
Status Answered
Topic revision: r8 - 22 Jan 2010, AtleBriskemyr - This page was cached on 23 Jun 2018 - 03:01.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy