This question about Using an extension: Answered

Natsearch fails after update of NatSkinPlugin and NatEditPlugin

Updated the following components to latest versions:

NatEditPlugin (v4.20, $Rev: 5550 (2009-11-17) $):
NatSkinPlugin (3.95, $Rev: 5563 (2009-11-17) $):

After than, the combo Search/GO field in the upper right fails

URL is:

http://wiki.myserver.local:85/bin/natsearch/System/NatSkinPlugin?limit=100&search=test

Nothing in either Apache or Foswiki log.

Search fields on WebHome continue to work with the URL:

http://wiki.myserver.local:85/bin/search/System/?search=test

Comparing the contents of /bin/natsearch, the previous working version concluded with

use Foswiki::UI;
use Foswiki::Plugins::NatSkinPlugin::Search; Foswiki::UI::run();
&Foswiki::Plugins::NatSkinPlugin::Search::searchCgi, 'natsearch' => 1);

The new version is:

use Foswiki ();
use Foswiki::UI ();
$Foswiki::engine->run();

Reverting the file appears to fix the search, but I presume there might have been intent there.

-- CraigBowers - 25 Nov 2009

Fails how? What error do you get? There was a problem with execute bit not being set properly on /bin/natsearch script. Tasks.Item8368 might be related, but perhaps there is a different problem here.

-- PaulHarvey - 26 Dec 2009

The latest version of NatSkin / NatSkinPlugin have got a Config.spec of its own that will add the needed switchboard configuration to lib/LocalSite.cfg if you go through a configure + save loop at least once.

-- MichaelDaum - 26 Dec 2009

QuestionForm edit

Subject Using an extension
Extension NatSkin
Version Foswiki 1.0.7
Status Answered
Topic revision: r5 - 10 Jan 2013, GeorgeClark - This page was cached on 12 Nov 2018 - 18:31.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy