This question about : Answered

WYSIWYG / TinyMCE not working with NatSkin

After installing NatSkin and all dependencies, when I edit pages, WYSIWYG editor is not working.

When you click edit (not edit wikitext, just regular edit), you get a wikitext editor and this title bar (not the WYSIWYG titelbar).

WYSIWYG Titlebar.jpeg

I tried toggling WYSIWYG on and off from settings and adding ;nowysiwyg=0 / ;nowysiwyg=1 to end of URL - does not help.

I tried reinstalling NatEditPlugin, TinyMCE and WYSIWYG. Confirmed all dependencies for NatEditPlugin are installed. Only setting in Site Preferences is "Set SKIN = nat"

Im not sure what is going on with my instance. Please help me diagnose if you can.

2/12/18: Performed some additional troubleshooting. No luck. Tried installing JQueryPlugin again. Tried disabling disableling all non-required plugins, even down to NatSKin. Issue persists. Re-enabled plugins. Turned on JQuery debugging, then tried debugging Java using FIrefox Developer Debugger. No errors, noting I can see.


On which page did you click on "Edit"? Try an empty one.

-- Main.MichaelDaum - 12 Feb 2018 - 13:00

HI Michael.

Thanks for your response. I figured it out. My colluegue sneaked a call out of the deactivation of WYSIWYG within SitePreferences without telling me and I didnt see it. Lol. All is working now.

BTW, I love using NatSkin. I noticed you are pretty much the creator, so thank you! Its awesome.

This issue can be closed.

-- 13 Feb 2018, TomMacLean

Thanks for your positive feedback. Enjoy.

-- Main.MichaelDaum - 13 Feb 2018 - 08:24

QuestionForm edit

Subject
Extension NatSkin
Version Foswiki 2.1.5
Status Answered
Related Topics
Topic revision: r5 - 13 Feb 2018, MichaelDaum - This page was cached on 18 Nov 2018 - 00:00.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy