cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Issue in browser: Answered

TinyMCEPlugin IE11 Support

-- ChrisKenward - 17 Aug 2016

Environment
  • Foswiki 2.0.2 / Foswiki 2.1.2
  • TinyMCEPlugin 1.3.0
  • Wysiwyg Plugin 8 Apr 2016
Users complain that Find and Replace is not working in IE 11: an error dialog is shown that says "This feature is not available in IE 11+ Upgrade TinyMCE to 4.x to get this functionality back."

Are there plans to upgrade TinyMCEPlugin to include TinyMCE v4?

******************************************************************************

I know, Internet Explorer isn't a fancy browser anymore, and in the end, will disappear, but in case you love it, here's a way to get FOSWIKI's TinyMCE search and replace work again in IE 11.

The default TinyMCE in Foswiki (from which version on?) 2.1.6 is 3.5.11 (see ~/pub/System/TinyMCEPlugin/tinymce/jscripts/tiny_mce/tiny_mce_src.js).

When you use Search and Replace in the TinyMCE editor, this is not possible in IE11+. You get the following message:

This feature is not available in IE 11+. Upgrade TinyMCE to 4.x to get this functionality back.

I tried the testing version from FOSWIKI (https://foswiki.org/Extensions/Testing/TinyMCEPlugin). However, this didn't work out well, since I wasn't able to save topics anymore (Do you want to leave this page…).

However, there is a workaround:
  • go to https://www.tinymce.com/download/older-releases/
  • download (het Prod version of) 3.5.12
  • Unpack the downloaded zip
  • go to ~/pub/System/TinyMCEPlugin/tinymce/jscripts/tiny_mce/plugins on your web server and rename the searchreplace folder there in searchreplace3.5.11
  • copy the searchreplace folder from the unpacked ~\tinymce_3.5.12\tinymce\jscripts\tiny_mce\plugins to your web server (see location above)
  • make sure the right owner and group are set recursively
  • clear the local cache of your Internet Explorer (Ctrl + Shift + Delete)
  • edit an arbitrary FOSWIKI topic and try to search / replace some text using the TinyMCE editor
  • hurray!
-- StijnBousard - 30 Mar 2018

The next "minor" Foswiki release, 2.2.0, will include the latest TinyMCE. At one point the Extension/Testing version of TinyMCE was working, however it also needs WysiwygPlugin. Some recent changes might also need an updated NatEdit, so I'll have to test this again and possibly release that one to Testing as well.

-- GeorgeClark - 30 Mar 2018

I've uploaded the upcoming 2.2 versions of the exensions to the Extensions/Testing web as: Note that all three have to be updated for TinyMCE to be functional.

-- GeorgeClark - 05 Apr 2018
 

QuestionForm edit

Subject Issue in browser
Extension TinyMCEPlugin
Version Foswiki 2.1.2
Status Answered
Related Topics
Topic revision: r5 - 05 Apr 2018, GeorgeClark - This page was cached on 19 Sep 2018 - 22:23.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy