cross
New Foswiki release 2.1.6 is available with important security fixes.
Sourceforge foswiki email lists being discontinued. Subscribe to the new Foswiki announce and discuss lists at MailingLists
This question about Installation of Foswiki: Answered

Left bar and theme not working in brand new install

I am at the very early stages of installing FOSWIKI 1.0.5 on a shared host. I installed TWiki a number of years ago and vaguely recall having a similar problem, which I solved at the time, but alas can't remember what I did..

Just after running configure for the first time, when I run foswiki it comes up, but just in plain text, with what should be the web left bar on the bottom. It looks like some files required for the default theme are are not accessible, but I don't see a problem with permissions. If someone could just point me in the right direction, I'd appreciate it.

Tim Wegner

Answer

First check: see if you can access the files through your browser. Look in the source code for a file xxxxxxx/style.css, paste that url in the browser and see if you can see it. If not, you need to set the access permissions of the files in the pub directory.

-- ArthurClemens - 31 May 2009

Answer#2

Thanks so much Arthur. Your suggestion wasn't exactly my problem, but you pointed me in the right direction. It turned out that the problem wasn't in the permissions themselves, but was in .htaccess in /pub. I needed to comment out the line:

php_flag engine off.

I saw that instruction to do that in InstallingOnBlueHost but was cautious and didn't do it because I was using a different host (emwd.com). Thanks again!

-- TimWegner - 31 May 2009

QuestionForm edit

Subject Installation of Foswiki
Extension
Version
Status Answered
Topic revision: r3 - 31 May 2009, TimWegner - This page was cached on 18 Aug 2018 - 12:20.

The copyright of the content on this website is held by the contributing authors, except where stated elsewhere. See Copyright Statement. Creative Commons License    Legal Imprint    Privacy Policy